shhelina
?>

Дан массив, состоящий из целых чисел. нумерация элементов начинается с 0. напишите программу, которая выведет элементы массива, номера которых четны

Информатика

Ответы

Кулагина_Владимир1179
Var a:array[0..100] of integer; 
n,i:integer; 
begin 
writeln('Введите количество элементов массива'); 
read(n); 
for i:=0 to n-1 do read(a[i]); 
for i:=0 to n-1 do 
if i mod 2=0 then write(a[i],' '); 
end.
tatyanakras911248
Задание 1.

3 кбайта= 3*1024*8=24576 бит

1 мбайт = 1*1024*8=8196 байт

4096 бит =4096\8\1024= 0.5 кбайта

2.5 мбайт=2.5*1024=2560 кбайт

Задача 2.

k-120 символов

N(мощность алфавита) = 512=> i=9 бит

I=k*i

I=120*9=1080 бит

Задача 3.

I=2 кб

k=4096 символов

N=2^i        I=k*i                i= 2*1024*8/4096=4

2^4=16 - ответ

Задача 4.

Племя мульти:

N=64 => i=6 бит

Значит 150*6=900 бит          

Племя пульти:                                

N=512 =>i=9 бит

Значит 50*9=450 бит

Задача 5.

I=8 кб

N=16 => i=4

k-?               k=I/i            k=8*1024*8/4=16 384 - всего символов

16 384/512=32 страницы

uuks2012

Это таблица истинности для логических функций. Галочка вверх означает логическое И, галочка вниз - логическое ИЛИ, уголок перед переменной - логическое НЕ. Это тема обширная, и так что если я представлю здесь решение это все равно вам не понять. Вам нужно почитать о логических функциях и таблицах истинности.

Вот как выглядит решение. Поставляем значения из таблицы истинности в варианты функций. Та функция, результат которой совпадает с результатом из таблицы, является ответом. В данном случае это номер 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив, состоящий из целых чисел. нумерация элементов начинается с 0. напишите программу, которая выведет элементы массива, номера которых четны
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ser7286
gavrilasmax05
Vladimirovna1370
marketing3
Александровна
Татьяна_Александра1114
vsemvsego306
Николаев
Bordo
Shcherbinin KOLIChEVA
ВладимировнаИП37
Aleksandr_Vasilev
Katkova
salesrawtogo
СергейНиколаевич
▲