kirillreznikov
?>

Пользователь вводит положительное целое число , не превышающее 10^9, нужно написать программу , которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр , меньших 7, требуется на экран вывести 0

Информатика

Ответы

modno-trikotazh
Program n1;
var  n,k,s:real;
i:integer;
begin
readln(n);
if (n<1000000000) and (n>0) then
begin
writeln('число=',n);
if n>=6 then
begin
k:=0;
s:=0;
while k<7 do
begin
s:=s+k;
k:=k+1;
end;
writeln('сумма цифр=',s);
end else
writeln('0');
end;
end.
VladimirovnaSimonov
Var
  n, sum: integer;
begin
  read(n);
  while n > 0 do
  begin
    if n mod 10 < 7 then
      sum := sum + n mod 10;
    n := n div 10
  end;
  writeln(sum);
end.
Viktoromto
Var m1,m2,m3:array of integer;
i,n:integer;
begin
  write('Введите размер массивов');
  readln(n);
  setlength(m1,n);
  setlength(m2,n);
  setlength(m3,n);
  //Заполнение массивов
  for i:=0 to n-1 do begin
    m1[i]:=random(21)-10;
    m2[i]:=random(21)-10;
    m3[i]:= m1[i]+m2[i];
  end;
  //Вывод массивов
  for i:=0 to n-1 do write(m1[i]:4);
  writeln;
  for i:=0 to n-1 do write(m2[i]:4);
  writeln;
  for i:=0 to n-1 do write(m3[i]:4);
  writeln;
end.

Тестовое решение:
Введите размер массивов 10
   7 -10   9  -4   8  -6  10   4   6   2
  10  -3  -2  -7   1   9   2   3   5  -6
  17 -13   7 -11   9   3  12   7  11  -4
yocrew13
1) 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 program program1; var s,subs:string;c:char;isOneNumber:boolean;p:byte;n,err:integer; begin writeln('‚Введите фразу'); readln(s); c:=s[1]; isOneNumber:=false; p:=pos(' ',s); while p<>0 do  begin  if p=1 then   begin   s:=copy(s,2,length(s));   p:=pos(' ',s);   continue;   end;  subs:=copy(s,1,p-1);  s:=copy(s,p+1,length(s));  p:=pos(' ',s);  val(subs,n,err);  if err<>0 then continue;  if (n=0) or (n>9) then continue;  isOneNumber:=true;  break;  end; if isOneNumber then writeln('‚ Есть числа, сосотоящие из одной цифры') else writeln('‚Нет чисел, состоящих из одной цифры'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Пользователь вводит положительное целое число , не превышающее 10^9, нужно написать программу , которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр , меньших 7, требуется на экран вывести 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Алена
svetegal
borisovaks496
artemka56rus
barekyan096140
Valentinovna
narkimry134
braigon974
lbeglarova6
polina0075880
ksv89
Nikolaevich_Vladimirovich1509
picsell
volkovaoksana19806037
coalajk
▲