Ольга
?>

Даны целые числа x, y, c. написать программу которая находит значение выражения x+y/2c в pascal

Информатика

Ответы

Yekaterina358

program test; var x, y, c: integer; total: real; begin    write('enter x, y, c: ');     readln(x, y, c);     total: =x+y/2*c;     writeln(x, '+', y, '/2*', c, '=', total);

    readln; end.

tetralek

Объяснение:

Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.

pryvalovo48

Первый шаг в отношениях между пользователем и программой –  это запуск программы пользователем. Затем можно выполнять в программе те действия, ради которых она и была создана.

Объяснение: Рассмотрим запуска программ:

 1)Из Главного меню можно запускать программы, которые в нем записаны.

Для примера возьмем стандартные программы. Дело в том, что Windows – не просто операционная система. В ее состав входит множество разнообразных прикладных программ или, как их называют приложений, такие как

калькулятор,графический редактор Paint,текстовые редакторы Блокнот и WordPad,служебные программы по обслуживанию дискаи др.

Стандартные программы в главном меню Windows XP

Эту группу программ называют Стандартные, потому что она входит в состав операционной системы и устанавливается вместе с установкой операционной системы.

Чтобы запустить, например, Калькулятор, надо пройти по маршруту: кнопка Пуск – Программы – Стандартные – название программы (“Калькулятор”).

2) При двойного щелчка по значку программы или по ярлыку на Рабочем столе Windows.

3) Щелчок по значку программы  в Панели задач Windows. Например, на рисунке после щелчка по значку будет открыт текстовый редактор MS Word.

4) При команды “Выполнить” в Главном меню Windows.

В открывшемся окне Запуск программы нужно указать открываемый файл, причем можно воспользоваться для этого кнопкой Обзор, которая откроет окно просмотра содержимого дисков и папок. В нем, открывая папки, нужно выделить и открыть запускающий файл программы. По умолчанию во всех папках будут показаны только запускающие и командные файлы, а также ярлыки.

5) Автоматический запуск программ, например:

при начальной загрузке Windows. Для того, чтобы это сделать, следует пройти по маршруту Пуск – Программы – Автозапуск.

Если поместить программы в меню Автозагрузка, то они будут автоматически запущены при начальной загрузке Windows.

при вставке в дисковод CD или DVD диска. При этом автоматически запускается программа, записанная на диске, правда, если автором диска не предусмотрено иное действие.

Иногда для избежания заражения вирусом автоматический запуск компакт-дисков отключают и сначала проверяют диск антивирусом.

по заданному графику. Такую возможность предоставляет встроенная в Windows программа-планировщик.

6) Двойной щелчок по значку или по имени программы в окне “Мой компьютер” или “Проводник”.

7) Двойной щелчок по значку или имени документа, обрабатываемого той или иной программой. Например, если щёлкнуть по значку с буквой «W», запустится программа MS

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны целые числа x, y, c. написать программу которая находит значение выражения x+y/2c в pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Руслан Руденко1262
Вечер добрый с информатикой
znaberd786
snip99
Popov Valentina1324
vdm4275
Егорова
vetrov1
Petrosienko_Larisa,1908
d2002
Amulenkov
uglichdeti
ТигранКалмыкова
tarasovs
madjk
a-zotova