15 ! нужно составить программу в паскаль. если сумма различных целых чисел х, у, z меньше 30, то заменить меньшее из у и х суммой двух других. в противном случае увеличить все числа на 10
Var x,y,z:integer; begin write('x='); readln(x); write('y='); readln(y); write('z='); readln(z); if x+y+x<30 then if x<y then x:=x+y else y:=x+y else begin x:=x+10; y:=y+10; z:=z+10 end; writeln('x=',x,' y=',y,' z=',z); end.
Пример: x=7 y=12 z=9 x=19 y=12 z=9
sisychev
18.11.2021
Реферат – сбор и представление исчерпывающей информации по заданной теме из различных источников, в том числе представление различных точек зрения по этому вопросу. При работе над проектом имеется похожий, реферативный этап, который является лишь частью проекта. Исследовательская работа – работа, связанная с решением творческой, исследовательской задачи с заранее неизвестным результатом. Исследование – это лишь этап проектной работы. Проект – работа, направленная на решение конкретной проблемы, на достижение оптимальным заранее запланированного результата. Проект может включать в себя элементы докладов, рефератов, исследований и других видов самостоятельной работы учащихся, но только как достижения результатов проекта.
Попова1271
18.11.2021
Var s:string; c1,cn:char; n:integer; begin Write('Введите натуральное число: '); Read(n); Str(n,s); c1:=s[1]; cn:=s[Length(s)]; if c1>cn then Writeln('Первая цифра больше последней') else if c1<cn then Writeln('Первая цифра меньше последней') else Writeln('Первая и последняя цифры одинаковы') end.
Тестовые решения Введите натуральное число: 362336 Первая цифра меньше последней
Введите натуральное число: 7341423 Первая цифра больше последней
Введите натуральное число: 4624 Первая и последняя цифры одинаковы
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
15 ! нужно составить программу в паскаль. если сумма различных целых чисел х, у, z меньше 30, то заменить меньшее из у и х суммой двух других. в противном случае увеличить все числа на 10
begin
write('x='); readln(x);
write('y='); readln(y);
write('z='); readln(z);
if x+y+x<30
then if x<y then x:=x+y else y:=x+y
else begin x:=x+10; y:=y+10; z:=z+10 end;
writeln('x=',x,' y=',y,' z=',z);
end.
Пример:
x=7
y=12
z=9
x=19 y=12 z=9