bogdanovaoksa
?>

Написать программу в pascal. напишите функцию выбора меньшего из целых чисел. используйте ее в программе выбора наименьшего из трех чисел.

Информатика

Ответы

Мунировна
Var a,b,c,m:integer;
function min(x,y:integer):integer;
begin
if x<y then min:=x else min:=y;
end;
begin
write('a='); readln(a);
write('b='); readln(b);
write('c='); readln(c);
m:=min(min(a,b),c);
writeln('min=',m);
end.

Пример:
a=5
b=3
c=8
min=3
СмыковаДарья1969
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

Var
 ar:array[1..n] of integer;
 i,j,k:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(-3,3);
   write(ar[i]:4);
  end;
 for i:=1 to n-1 do {ммм, пузырёк. Но за быструю сортировку здесь репортят}
  for j:=i+1 to n do
   if ar[i]>ar[j] then
    begin
     k:=ar[i];
     ar[i]:=ar[j];
     ar[j]:=k;
    end;
 writeln;
 writeln('Sorted array:');
 for i:=1 to n do
 write(ar[i]:4);
 writeln;
 for i:=1 to n do
 if ar[i]=0 then
  begin
   write('Index of 0 is ',i);
   break;
  end;
end.

Пример работы программы:
First array:
  -2  -3   0  -3   3
Sorted array:
  -3  -3  -2   0   3
Index of 0 is 4
tarasowamash4
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=10;

 Var
 ar:array[1..n] of integer; 
sum,i:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(-50,50);
   write(ar[i]:4);
   sum:=sum+ar[i];
  end;
 writeln;
 writeln('Sum=',sum);
 writeln('Final array:');
 for i:=1 to n do
  begin
   ar[i]:=ar[i]*5;
   write(ar[i]:6);
  end;
end.

Пример работы программы:
First array:
  24  45  28  40 -48  -7  29  43 -23  18
Sum=149
Final array:
   120   225   140   200  -240   -35   145   215  -115    90

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal. напишите функцию выбора меньшего из целых чисел. используйте ее в программе выбора наименьшего из трех чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yuklimochkina3
sisychev
Shitikov-M.A.1307
Dmitrievna Lvovich
victors
marinakmaa86
grenysherg2873
rmitin
impuls20125948
potap-ver20065158
SlavaA99
yakovlevasvetlanalvovna209
dailyan539
vasiliiparshin7668
Lugovoi
▲