tpomyleva6
?>

Только для ! составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. на экран должен быть выведен результат выполнения соответствующего арифметического действия. для ввода знака использовать переменную типа char.

Информатика

Ответы

websorokin
Var 
s: char; 
a, b: real;
begin 
Write('Введите два числа '); 
Readln(a, b); 
Write('Введите действие (+, -, *, /) - '); 
Readln(s); 
case s of    
'+': writeln(a, ' + ', b, ' = ', a + b);   
'-': writeln(a, ' - ', b, ' = ', a - b);   
'*': writeln(a, ' * ', b, ' = ', a * b);   
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
andreich97
Var  Ch : Char;
  a,b : Integer;
Begin
  Readln(a,b);
  Readln(Ch);
  Case Ch of
   '+' : Writeln(a+b);
   '-' : Writeln(a-b);
   '*' : Writeln(a*b);
   '/' : Writeln(a/b);
  end;
end.
leeka152522
1.Какое устройство компьютера моделирует мышление человека?
-Процессор

2.Действия над исходной информацией (фактами) в соответствии с некоторыми правилами - это
-обработка информации

3.Из предложенных сообщений выбрать правило
-при умножении простых дробей их числители и знаменатели перемножаются

4.Для кого, вероятнее всего, будет информативным следующее сообщение: «Программа - это алгоритм, записанный на языке программирования»?
-начинающий программист

5.Где хранится выполняемая в данный момент программа и обрабатываемые ею данные?
-в оперативной памяти

6.Какое устройство компьютера осуществляет процесс дискретизации звука?
-звуковая карта

7.Информативность сообщения, принимаемого человеком, определяется
-наличием новых знаний и понятностью

8.Вместо многоточий вставьте соответствующие понятия: «Каталог содержит информацию о ..., хранящихся в...»
A) файлах, внешней памяти

9.Указать команду(ы), при выполнении которой(ых) выделенный фрагмент попадает в буфер обмена
В) вырезать и копировать

10.Какие из перечисленных действий относятся к форматированию текста?
-установка режима выравнивания

11.В прикладное программное обеспечение входят:
В) текстовые редакторы

12.Операционная система - это
-комплекс программ, организующих управление работой компьютера и его взаимодействие с пользователем

13.Предложены команды
5Сделать диск А текущим.
2Создать каталог TOWN
3Создать каталог STREET
1Создать файл Home.txt
4Войти в созданный каталог
Расположить пронумерованные команды так, чтобы был получен алгоритм, с которого на пустой дискете создается файл с полным именем A:\TOWN\STREET\Home.txt
Б) 5,2,3,1

14.Для хранения текста требуется 84000 бита. Сколько страниц займет этот текст, если на странице размещается 30 строк по 70 символов в строке? Для кодирования текста используется таблица кодировки, состоящая из 256 символов.
84000/(log(256)/log(2))/30/70 = 5

15.Книга состоит из 64 страниц. На каждой странице 256 символов. Какой объем информации содержится в книге, если используется алфавит из 32 символов?
А) 81920 байтов Б) 40 Кбайт В)10 Кбайт Г) 16 Кбайт Д) 64 Кбайт
64*256*(log(32)/log(2)) /8/1024 = 10

16.Сколько символов содержит сообщение, записанное с символьного алфавита, если его объем составил 1/16 часть Мегабайта?
(1/16)*1024*1024*8/(log(16)/log(2)) = 131072

17.Сколько памяти занимает графическое изображение, если его размер 40x60 и для кодирования цвета пикселя используется двоичный код из 32-х битов.
А) 2400 байтов  Б) 2100 байтов  В) 960 байтов Г) 9600 байтов    Д) 12000 байтов
40*60*32/8 = 9600

18.Текст занимает 0,25 Кбайт памяти. Сколько символов содержит этот текст, если используется таблица кодировки, состоящая из 256 символов?
0.25*1024*8/(log(256)/log(2)) = 256

19.Сколько битов информации содержится в сообщении объемом четверть Килобайта?
1/4*1024*8 = 2048
anton1969026203
Следует отметить, что 1 условие выполняется во всех цепочках, а значит его можно не рассматривать.
Рассмотрим каждую комбинацию отдельно:
HDEE
2 условие - true
3 условие - true
4 условие - true
Подходит
HHAE
2 условие - true
3 условие - false(H на 2 месте)
HEAE
2 условие - true
3 условие - true
4 условие - true
Подходит
AHAH
2 условие - true
3 условие - true
4 условие - true
Подходит
AEAD
2 условие - true
3 условие - true
4 условие - true
Подходит
AEED
2 условие - false(E на 3 месте)
CAEH
2 условие - false(A не входит в список допустимых значений)
EHAD
2 условие - true
3 условие - false(E не входит в список допустимых значений)
CDEA
2 условие - true
3 условие - true
4 условие - false(A не входит в список допустимых значений)
ответ: 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Только для ! составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. на экран должен быть выведен результат выполнения соответствующего арифметического действия. для ввода знака использовать переменную типа char.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgusikok
Марюк-Мубариз
fox-cab3444
vyborovvs
pafanasiew
Алексеевна_Валентиновна
Борисович409
Анатольевич1707
Valerevna
Mikhailovich_Viktoriya
Эдуардович873
svetegal
sv455umarketing74
nadnuriewa8110
len4ik1986
▲