Анатольевич1707
?>

В текстовом редакторе Блокнот написать программу на языке Pascal для решения следующей задачи: 1. Ввести два числа и вывести значение периметра и площади прямоугольника со сторонами, равными введенным значениям. 2. Ввести два числа и вывести большее из них. 3. Ввести четыре числа. Сравнить суммы двух первых и двух последних чисел, вывести меньшую из них. 4. Ввести три числа и вывести меньшее из них. 5. Вести два числа. Если оба числа положительны, вывести их суму, оба отрицательны – вывести их произведение, в обратном случае вывести разность большего и меньшего из них. 6. Ввести число и возвести его в квадрат. Повторять операцию до тех пор, пока результат не станет больше 1000. Вывести полученное значение. 7. Ввести два числа. Удваивать меньшее из них до тех пор, пока оно не станет больше второго числа. Вывести полученное значение.

Информатика

Ответы

Щуплова Александр
Const 
    n = 3;
    k = 3;
var
  i,j,s1,s2:integer;
  a:array[1..n,1..k] of integer;
begin
  s1:=0;
  s2:=0;
for i:=1 to n do
    for j:=1 to k do
    begin
     Writeln('Введите a[',i,',',j,']:');
     readln(a[i,j]);
     if (a[i,j]>0) and (i<>j) then s1:=s1+a[i,j];
     if (a[i,j]<0) and (i<>j) then s2:=s2+a[i,j];
    end;
  if s1>s2 then
   for j:=1 to k do
    begin
      a[1,j]:=s1;
      a[n,j]:=s1;
    end;
  if s2>=s1 then
    for i:=1 to n do
    begin
     a[i,1]:=s2;
     a[i,k]:=s2;
    end;
 writeln('Полученный массив:');
  for i:=1 to n do
   begin
     for j:=1 to k do
   write('a[':4,i,',',j,']=',a[i,j]);
   writeln;
   end;
end.
Радецкая264
PascalABC.NET

const   
 n = 3;      
var   
a : array [1..n,1..n] of string;   
smax : string;   
i,j,lmin,lmax,km : integer; 
  
begin 
lmax := 0; 
smax := '';
    
for i := 1 to n do   
for j := 1 to n do   
begin     
readln (a[i,j]);     
if Length (a[i,j]) > lmax then       
begin       
smax := a[i,j];       
lmax := Length (a[i,j]);       
end;          
end;
    
lmin := Length (a[1,1]); 
km := 1;
 
for i := 2 to n do   
if Length (a[i,i]) < lmin then   
begin     
lmin := Length (a[i,i]);     
km := i;   
end; 
       
writeln (); 
for i := 1 to n do   
begin   
for j := 1 to n do     
write (a[i,j],' ');   
writeln ();   
end; 
writeln ();    
for i := 1 to n do   
begin   
for j := 1 to n do     
if (i = km) and (j = km) then     
write (smax,' ')     
else     
write (a[i,j],' ');   
writeln ();   
end;    
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В текстовом редакторе Блокнот написать программу на языке Pascal для решения следующей задачи: 1. Ввести два числа и вывести значение периметра и площади прямоугольника со сторонами, равными введенным значениям. 2. Ввести два числа и вывести большее из них. 3. Ввести четыре числа. Сравнить суммы двух первых и двух последних чисел, вывести меньшую из них. 4. Ввести три числа и вывести меньшее из них. 5. Вести два числа. Если оба числа положительны, вывести их суму, оба отрицательны – вывести их произведение, в обратном случае вывести разность большего и меньшего из них. 6. Ввести число и возвести его в квадрат. Повторять операцию до тех пор, пока результат не станет больше 1000. Вывести полученное значение. 7. Ввести два числа. Удваивать меньшее из них до тех пор, пока оно не станет больше второго числа. Вывести полученное значение.
Ваше имя (никнейм)*
Email*
Комментарий*