evatautes
?>

Python. 80 . решить с циклов, диапазонов 1)напишите программу, которая получает натуральные числа a и b (a пример: введите границы диапазона: 10 20 11 13 17 19 2)в магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг. как купить ровно 185 кг мастики, не вскрывая ящики? сколькими можно это сделать? 3)ввести натуральное число n и вывести все натуральные числа, не превосходящие n и делящиеся на каждую из своих цифр. пример: введите n: 15 1 2 3 4 5 6 7 8 9 11 12 15

Информатика

Ответы

apro3444595
Задание №1.

k = int(input('Начало диапазона '))
n = int(input('Конец диапазона '))
a = [0] * n # создание массива с n количеством элементов
for i in range(n): # заполнение массива
   a[i] = i
a[1] = 0

m = 2 # замена на 0 начинается с 3-го элемента

while m < n: # перебор всех элементов до заданного числа
  if a[m] != 0:
     j = m * 2
    while j < n:
        a[j] = 0
        j = j + m
       m += 1

# вывод простых чисел на экран
b = []
for i in a:
      if a[i] != 0 and i >= k:
      b.append(a[i])

del a
print(b)

Задание №2

count = 0
for i in range(13):
    for j in range(11):
        for k in range(9):
            if 185 == i*15+j*17+k*21:
                count += 1
                print(i,j,k)
print('Всего

Задание №3

x = int(input())
print('\n'.join(
str(n) for n in range(x+1)
if all(x != 0 and n % x == 0 for x in map(int, str(n
molodoychek
#include <iostream>
#include <math.h>
using namespace std;

class NumHandler
{
int number;

public:
NumHandler(int n): number(n) {}

int getDigitCount()
{
int ret = 1, tested = 1, div;
while (true) {
div = (int) number / tested;
if (div == 0) {
return ret - 1;
}
else {
ret++;
tested *= 10;
}
}
}

int getDigitSum()
{
int ret = 0,
tenMult = pow(10, getDigitCount() - 1),
div;
while (tenMult >= 1) {
div = (int) number % (tenMult * 10) / tenMult;
ret += div;
tenMult /= 10;
}
return ret;
}

int getLastDigit()
{
return number % 10;
}
};

int main()
{
int num;
cout << "n = ";
cin >> num;
NumHandler handler(num);
cout << endl;
cout << "Число цифр: " << handler.getDigitCount() << endl;
cout << "Сумма цифр: " << handler.getDigitSum() << endl;
cout << "Последняя цифра: " << handler.getLastDigit() << endl;
return 0;
}
olesya-cat8601
Стиль - это настройки вида какого либо обьекта, если он создается динамически, конечно
Скорее всего имеются ввиду стили для веб страниц. Это так называемые CSS - Cascading Style Sheets — каскадные таблицы стилей
Они могут быть как встроенными в html документ, идти отдельным файлом CSS(или несколькими) или конкретно статистически задаваться для некого элемента через аттрибут style. Обычно идет некая смесь всех 3 вариантов.

Пример форматирования текста
p{
  font-size: 1.5em; /*размер*/
  color: #EE9966; /*цвет*/
  font-weight: bold; /*жирность*/
  font-family: Verdana /*шрифт*/
}

Надеюсь понятно

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python. 80 . решить с циклов, диапазонов 1)напишите программу, которая получает натуральные числа a и b (a пример: введите границы диапазона: 10 20 11 13 17 19 2)в магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг. как купить ровно 185 кг мастики, не вскрывая ящики? сколькими можно это сделать? 3)ввести натуральное число n и вывести все натуральные числа, не превосходящие n и делящиеся на каждую из своих цифр. пример: введите n: 15 1 2 3 4 5 6 7 8 9 11 12 15
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ruslan374
Смирнов_Андрей691
Alekseevich1012
Yevgenii_Gurtovaya1532
kristinagaspa62
astenSA
Александра_Наталья1417
mstapottery
Евгеньевна_Хусинов
potapin
Azarenkoff
phmad7
kashschool3
elenak26038778
silicon-films3375