#include <iostream>
#include <string.h>
using namespace std;
#define MAX 128
char str[MAX], alf[MAX];
int main()
{
puts("Input name: ");
gets(str);
strlwr(str);
for(int i = 0; i <= 'z' - 'a'; i++)
alf[i] = 'a' + i;
for(int i = 0; i < strlen(str); i++)
if ((str[i] >= 'a') && (str[i] <= 'z'))
alf[str[i] - 'a'] = '0';
cout << "Letters that are not in the name: ";
for(int i = 0; i <= 'z' - 'a'; i++)
if (alf[i] != '0')
cout << alf[i] << " ";
return 0;
}
Вводится натуральное число N (N ≤ 1000000). Затем вводятся N целых чисел, не превосходящих по абсолютному значению 2³¹. Найти количество чисел, которые заканчиваются на 5. Если такие числа есть, вывести максимальное из них.
Чтобы определить последнюю цифру числа, воспользуемся оператором взятия остатка от деления. Чтобы можно было смотреть последнюю цифру у отрицательных чисел, будем брать остаток по модулю.
var
i, n, k, max: longint;
a: array[1..1000000] of longint;
begin
read(n);
max := -32767;
k := 0;
for i := 1 to n do
begin
read(a[i]);
if abs(a[i] mod 10) = 5 then
begin
k := k + 1;
if a[i] > max then max := a[i];
end;
end;
write(k, ' ');
if k <> 0 then write(max);
writeln;
end.
По условию задачи можно обойтись и без хранения массива. Такой код вложен в решение.
Поделитесь своими знаниями, ответьте на вопрос:
Посчитайте сумму по следующему правилу s= 0+1+2*2+3*3*3+4*4*4*4 (и так от 0 до 10 составить программу паскаль
s: integer;
Begin
for var i := 1 to 10 do
s := s + power(i,i);
write(s);
end.