VadimovichSvetlana622
?>

9класс, информатика, не надо "намудренно" все делать, чтоб было просто понятно : ) . : написать программу нахождения количества чётных чисел в массиве случайных чисел.

Информатика

Ответы

vladimir152
//Pascal ABC.NET v3.0 сборка 1111

Var
 ar:array[1..10] of integer;
 i,k:integer;
begin
 randomize;
 k:=0;
  writeln('Array:');
   for i:=1 to 10 do
    begin;
     ar[i]:=random(30);
      write(ar[i]:4);
       if ar[i] mod 2=0 then k:=k+1;
    end;
 writeln;
 write('Res=',k);
end.

Пример работы кода:
Array:
  21   2  10  22  21  24  29  13  29  28
Res=5
shmidt

from builtins import print

a = int(input())

b = int(input())

c = int(input())

d = int(input())

if (a + b + c + d) == (a * b * c * d):

  print('Сумма и произведения равны')

else:

  if (a + b + c + d) < (a * b * c * d):

      print('Cумма меньше произведения')

  else:

      print('Сумма больше произведения')

#2

sum = 0

for i in range(4):

  a = int(input())

  if a > 0:

      sum+=a

print(sum)

# 3

sum = 0

for i in range(4):

  a = int(input())

  if a < 0:

      sum += a

print(sum)

# 4

minus = 0

plus = 0

null = 0

for i in range(4):

  a = int(input())

  if a < 0:

      minus += 1

  else:

      if a > 0:

          plus += 1

      else:

          null += 1

print('Положительных {}, отрицательных {}, нулей {}'.format(plus, minus, null))

# 5

a = int(input())

b = int(input())

polusum = (a * b) / 2

ydvoen = 2 * a * b

if a > b:

  a = polusum

  b = ydvoen

else:

  b = polusum

  a = ydvoen

print(a, b)

# 6

z = []

for i in range(3):

  z.append(input())

if z[0] == min(z):

  z[0] = 0

else:

  if z[1] == min(z):

      z[1] = 0

  else:

      z[2] = 0

print(z)

#7

z = []

for i in range(4):

  z.append(int(input()))

print(max(z)-min(z))

# 8

M = 0

kvartal = 0

M = int(input())

if (M > 1) and (M < 4):

  kvartal = 1

  print('Квартал - ', kvartal)

else:

  if (M > 3) and (M < 7):

      kvartal = 2

      print('Квартал - ', kvartal)

  else:

      if (M > 6) and (M < 10):

          kvartal = 3

          print('Квартал - ', kvartal)

      else:

          if (M > 9) and (M < 13):

              kvartal = 4

              print('Квартал - ', kvartal)

if kvartal == 0:

  print('Введён неккоректный месяц')

# 9

list = ['крыса', 'корова', 'тигр', 'заяц', 'дракон', 'змея', 'лошадь', 'овца', 'обезьяна', 'петух', 'собака', 'свинья']

god = int(input())

opred = (god - 1995) % 12 - 1

print(list[opred])

Объяснение:

svetasvetlana429

# 1

from builtins import print

a = int(input())

b = int(input())

c = int(input())

d = int(input())

if (a + b + c + d) == (a * b * c * d):

   print('Сумма и произведения равны')

else:

   if (a + b + c + d) < (a * b * c * d):

       print('Cумма меньше произведения')

   else:

       print('Сумма больше произведения')

#2

sum = 0

for i in range(4):

   a = int(input())

   if a > 0:

       sum+=a

print(sum)

# 3

sum = 0

for i in range(4):

   a = int(input())

   if a < 0:

       sum += a

print(sum)

# 4

minus = 0

plus = 0

null = 0

for i in range(4):

   a = int(input())

   if a < 0:

       minus += 1

   else:

       if a > 0:

           plus += 1

       else:

           null += 1

print('Положительных {}, отрицательных {}, нулей {}'.format(plus, minus, null))

# 5

a = int(input())

b = int(input())

polusum = (a * b) / 2

ydvoen = 2 * a * b

if a > b:

   a = polusum

   b = ydvoen

else:

   b = polusum

   a = ydvoen

print(a, b)

# 6

z = []

for i in range(3):

   z.append(input())

if z[0] == min(z):

   z[0] = 0

else:

   if z[1] == min(z):

       z[1] = 0

   else:

       z[2] = 0

print(z)

#7

z = []

for i in range(4):

   z.append(int(input()))

print(max(z)-min(z))

# 8

M = 0

kvartal = 0

M = int(input())

if (M > 1) and (M < 4):

   kvartal = 1

   print('Квартал - ', kvartal)

else:

   if (M > 3) and (M < 7):

       kvartal = 2

       print('Квартал - ', kvartal)

   else:

       if (M > 6) and (M < 10):

           kvartal = 3

           print('Квартал - ', kvartal)

       else:

           if (M > 9) and (M < 13):

               kvartal = 4

               print('Квартал - ', kvartal)

if kvartal == 0:

   print('Введён неккоректный месяц')

# 9

list = ['крыса', 'корова', 'тигр', 'заяц', 'дракон', 'змея', 'лошадь', 'овца', 'обезьяна', 'петух', 'собака', 'свинья']

god = int(input())

opred = (god - 1995) % 12 - 1

print(list[opred])

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

9класс, информатика, не надо "намудренно" все делать, чтоб было просто понятно : ) . : написать программу нахождения количества чётных чисел в массиве случайных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anatolevich-sergeevna
AndreiFaikov1943
Maksimova1320
mrropevvv
tanyatanyat
nata27-73589
Albina
italiankarest
vitaldicky349
сергеевич1958
muz-cd
Designer
diana-020
shajmasha
navi35374