zaschitin48
?>

Нужно написать программу в "паскале" для перевода из любых систем исчисления в десятичную.

Информатика

Ответы

vardartem876
Var
  n, k, i: integer;
  s: string;
begin
  write('Введите число: ');
  read(s);
  write('Введите исходную систему счисления: ');
  read(k);
  for i := 1 to length(s) do
    n := n * k + ord(s[i]) - 48;
  write(s, '(2) = ', n, '(10)');
end.

Пример работы программы:
Введите число: 101000111000111
Введите исходную систему счисления: 2
101000111000111(2) = 20935(10)
Николаевна

Program YouName;

Uses crt; // Использование модуля crt.

Const e = 2.71828; // Объявление константы e.

Var // Раздел для описания переменных.

m,n: Integer; // Объявляем целочисленные переменные.

x,u,y: Single; // Объявляем дробные переменные.

Label check1, check2; // Объявляем метки для оператора Goto.

Begin // Начало "тела" программы.

 check1: // Метка для без условного перехода с оператора Goto.

write('Введите m: '); // Вывод текстового сообщения на экран консоли.

// {$I-} - это деректива, которая перехватывает вывод ошибок.

// т.e., если во время выполнение программы между {$I-} и {$I+} не будет ошибок,

// то значение IOResult будет равно 0. Если во время выполения программы произойдет ошибка,

// то программа не остановится, а задаст значение IOResult неравное 0.

// {$I+} соответственно отключает дерективу.

{$I-} // Включение директивы.

readln(m); // Ввод значения переменной m.

{$I+} // Отключение директивы

If IOResult <> 0 then // Если IOResult не равно 0 (т.е есть ошибки во время включенной директивы $I), то..

  Begin // Начало подпрограммы.

   writeln('Вы ввели неизвестный символ.'); // Вывод текстового сообщения на экран консоли.

   writeln('Введите число'); // Вывод текстового сообщения на экран консоли.

   Goto check1; // Переход на метку check1

  End; // Конец подпрограммы.

check2: // Метка для без условного перехода с оператора Goto.

write('Введите n: '); // Вывод текстового сообщения на экран консоли.

{$I-} // Включение директивы.

readln(n); // Ввод значения переменной n.

{$I+} // Отключение директивы.

If IOResult <> 0 then // Если IOResult не равно 0 (т.е есть ошибки во время включенной директивы $I), то..

  Begin // Начало подпрограммы.

   writeln('Вы ввели неизвестный символ.'); // Вывод текстового сообщения на экран консоли.

   writeln('Введите число'); // Вывод текстового сообщения на экран консоли.

   Goto check2; // Переход на метку check2

  End; // Конец подпрограммы.

x:=(m*n-exp(ln(e)*((-m)*0.7)))/(2.67); // Вычисление x

y:=ln(2)*(m+1); // Вычисление y

u:=0.125*sqrt(x/y)+exp(ln(e)*cos(x-y)); // Вычисление u

writeln(u:0:4); // Вывод текстового сообщения на экран консоли.

// u:0:4 - это задает переменной u четыре знака после запятой.

End. // Конец "тела" программы.

ирина Альбертовна
Информатика- дисциплина, изучающая структуру и общие свойства научной информации, а также закономерности её создания, преобразования, передачи и использования в различных сферах человеческой деятельности.

текстовый редактор-самостоятельная программа или компонент программного комплекса , предназначенная для создания и изменения текстовых данных вообще и текстовых файлов в частности

графический редактор- программа, осуществляющая работу с графической информацией (Штриховыми и растровыми изображениями).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу в "паскале" для перевода из любых систем исчисления в десятичную.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dmitrii sergei463
raa-0485428
Олег2014
violettamakhina2537
MN-Natusik80
saint158
Шарабанов
alexst123012225
Tane4ka2110
Vasilevna_Mikhail19
expo3217
prianik6
Tarapovskaya
mariy-inkina8
vikola2008
▲