Иван1764
?>

Ввести с клавиатуры 2 целых числа: m, n. если n ≤ m, то вывести 1, в противном случае — любое другое число. напишите программу в паскаль.

Информатика

Ответы

gladkihvv
Var
m, n: integer;
begin
readln(m, n);
if n <= m then
writeln(1)
else
begin
randomize;
writeln(random(50));
end;
end.
versalmoda2971
Для удобства вычислений переведём размер сканируемого изображения в дюймы: 20,32 × 20,32 (см) = 8 × 8 (inch).

Сначала найдём количество пикселей по горизонтали, по вертикали, затем общее количество пикселей, исходя из разрешающей сканера. Зная, что каждый пиксель кодируется 4 битами, найдём объём памяти, необходимый  для хранения графической информации, что и будет являться информационным объёмом файла.

1)    600 × 8 = 4800 (px) – количество пикселей по горизонтали.

2)    1200 × 8 = 9600 (px) – количество пикселей по вертикали.

3)    4800 × 9600 = 46 080 000 (px) – всего пикселей.

4)    46 080 000 × 4 = 184 320 000 (bit) = 22 500 (KB)

ответ: полученный графический файл будет иметь объём 22 500 килобайт.
jgaishun756
Точнее сказать - чем word отличается от программы Writer из пакета OpenOffice.
Word имеет больше функций. Это важно тем, кто много профессионально работает с текстами. Кстати, Word 2010 умеет сохранять в PDF.
Зато Writer может читать все форматы Word, а Word не может читать формат Writer - формат .odt.
Word - платный.
Если сравнивать OpenOffice с Word 2007 и выше, то они отличаются друг от друга совершенно разным расположением кнопочек и панелей. Если ты привык к Word, то тяжело привыкать к OpenOffice. И наоборот. Это я знаю по себе. Но это - дело привычки. Есть целые предприятия, которые перешли но OpenOffice.
Еще могу сказать, что Writer дольше запускается. Правда, потом работает без тормозов.
Вывод: нельзя сказать, какой лучше. Если для себя - то достаточно OpenOffice поставить, ибо он уже стабильный и по-честному бесплатный.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ввести с клавиатуры 2 целых числа: m, n. если n ≤ m, то вывести 1, в противном случае — любое другое число. напишите программу в паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

atlantika7
DudukinSerega2507834
Суравцова_Алексей669
zoomagazinkotmatroskin
frame45
nastikak8
melissa-80
rmitin
Olga-Borisovna
lavr74
Александрович_Викторовна
dmitrijku
glebshramko
rusmoney92
devochkadafka624
▲