devochkadafka624
?>

Написать программу, которая получает два целых числа A и B (0 < A < B) и выводит все натуральные числа в интервале от A до B.

Информатика

Ответы

skryabinamaria
beginvar (a,b) := ReadInteger2;(a..b).Print end.

или

var a,b:integer; beginread(a,b); for var i:= a to b do print(i) end.

Пример работы:


Написать программу, которая получает два целых числа A и B (0 < A < B) и выводит все натуральн
endyurans2ooo

1Найдите значение выражения 8F – 80 в шестнадцатеричной системе счисления. В ответе запишите вычисленное значение в десятичной системе счисления.

Решение.

Переведём число 8F16 из шестнадцатеричной в десятичную систему счисления:

8F16 = 14310.

Переведём число 8016 из шестнадцатеричной в десятичную систему счисления:

8016 = 12810.

Найдём разность: 143 − 128 = 15.

2

Найдите значение выражения 1116 + 118 : 112. ответ запишите в двоичной системе счисления.

Решение.

Переведем все числа в десятичную систему счисления, выполним действия и переведем результат в двоичную систему счисления:

1116 = 16 + 1 = 1710,

118 = 8 + 1 = 910,

112 = 2 + 1 = 310,

17 + 9 : 3 = 17 + 3 = 2010,

20 = 16 + 4 = 10100 и маленькая два вместе с ответом

3

Вычислите значение выражения B916 − 2718. В ответе запишите вычисленное значение в десятичной системе счисления.

Ре­ше­ние.

Пе­ре­ведём числа в де­ся­тич­ную си­сте­му счис­ле­ния:

B916 = 18510

2718 = 18510

Найдём раз­ность: 185 − 185 = 0.

ответ дай лучшего ответа

Елена_Зайкин1665
// PascalABC.NET 3.2, сборка 1447 от 22.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в массиве:');
  var m:=ReadInteger('Количество колонок в массиве:');
  Writeln('*** Исходный массив [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(5); Writeln(5*a.ColCount*'-');
  a.Cols.Select(x->Format('{0,5}',x.Where(y->y<0).Sum)).Print('');
  Println(' - суммы отрицательных');
end.

Пример
Количество строк в массиве: 5
Количество колонок в массиве: 9
*** Исходный массив [5,9] ***
  -43  -96   34   82    3   92  -59   31   35
   65   94   76   66   90  -39   26  -24   83
   73  -92   94  -94   44  -35  -66   87  -46
   90   56  -37  -60   -9   94    9  -76  -58
  -16   97   65  -21  -86   64  -20   46  -26

  -59 -188  -37 -175  -95  -74 -145 -100 -130 - суммы отрицательных

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая получает два целых числа A и B (0 < A < B) и выводит все натуральные числа в интервале от A до B.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bochkarevazh
kbndbyb6
Хохлов
mnkrasnova
anatolevich1931
rmitin
Узлиян Фурсов1488
thebest59
Суравцова_Алексей669
sev-94428
pivenraisa
Yurevich1344
NikolayGoncharov
Bella
atlantika7
▲