Alsergus7811
?>

Решить на pasсal. во всех массив состоит из 10 элементов и задаётся из интервала от 1 до 99. 1.написать программу, которая выводит на экран все четные элементы массива и их количество. 2.написать программу, которая выводит на экран все двузначные элементы массива и их количество. 3.написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по индексу написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по значению). 5.написать программу, которая выводит на экран количество элементов оканчивающихся на 5.

Информатика

Ответы

Alekseevich_Elena
1. var a: array[1..10] of integer;
          i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  kol := 0;
  for i := 1 to 10 do
    if a[i] mod 2=0 then
    begin
      kol := kol + 1;
      write(a[i],' ');
    end;
  writeln;
  writeln(kol);
End.
2. var a: array[1..10] of integer;
    i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  kol := 0;
  for i := 1 to 10 do
    if a[i] > 9 then
    begin
      kol := kol + 1;
      write(a[i],' ');
    end;
  writeln;
  writeln(kol);
End.
3. var a: array[1..10] of integer;
    i: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  for i := 1 to 10 do
    if a[i] mod 2=0 then write(a[i],' ');
  for i := 1 to 10 do
    if a[i] mod 2=1 then write(a[i],' ');
End.
4. var a: array[1..10] of integer;
    i, r: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  i := 1;
  while i < 10 do
    if a[i+1] < a[i] then begin
      r := a[i+1];
      a[i+1] := a[i];
      a[i] := r;
      i := 1;
    end else i := i + 1;
  for i := 1 to 10 do
    if a[i] mod 2=0 then write(a[i],' ');
  for i := 1 to 10 do
    if a[i] mod 2=1 then write(a[i],' ');
End.
5. var a: array[1..10] of integer;
    i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  for i := 1 to 10 do
    if a[i] mod 10 = 5 then kol := kol + 1;
  writeln(kol);
End.
akbmaslafarkop3175
Var
  m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
  s:real;
  a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
  begin
  writeln('Вводите элементы строки ',i,' по одному');
  for j:=1 to n do    readln(a[i,j]);
  end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
  for j:=1 to n do
    begin
    if a[i,j]<min then
      begin
      min:=a[i,j];
      imn:=i;
      jmn:=j;
      end;
    if a[i,j]>max then
      begin
      max:=a[i,j];
      imx:=i;
      jmx:=j;
      end;
    end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
  begin
  for j:=1 to n do    write(a[i,j]:5);
  writeln;
  end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
  if a[i,j]<0 then
    begin
    s:=s+a[i,j];
    k:=k+1;
    end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);  
end. 
tatur-642789

Код + скриншот (код и вывод компилятора). Строки с #... - комментарии. Если хотите, что бы показывался весь процесс работы программы - уберите только "#". Если не нужно - можете удалить строки с #... (не обязательно):

N = int(input("N = "))

fact_N = 1

for i in range(1,N+1):

   fact_N *= i

#print("Factorial N = ",fact_N)

count_dividers = 0

for divider in range(1,fact_N+1):

   if (fact_N % divider == 0):

       count_dividers += 1

#        print(count_dividers,"divider = ",divider)

print("Amount of dividers for '",N,"' - ",count_dividers)


Напишите программу на питоне Делители факториала По заданному натуральному числу N необходимо вычисл

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на pasсal. во всех массив состоит из 10 элементов и задаётся из интервала от 1 до 99. 1.написать программу, которая выводит на экран все четные элементы массива и их количество. 2.написать программу, которая выводит на экран все двузначные элементы массива и их количество. 3.написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по индексу написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по значению). 5.написать программу, которая выводит на экран количество элементов оканчивающихся на 5.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Viktorovna
Sergei_sergei
dentalfamily
julia3594265843
deshkina82
lika080489
Сергей_Евгеньевич1255
Vrpeshka
airon-082054
saytru5850
Alekseevich_Viktorovna
николаевич-Елена988
Ragim777hazarovich
Kuzina Sergeevna
borvalmok432