takerra
?>

Часовая стрелка повернулась с начала суток на d градусов. определите, сколько сейчас целых часов h и целых минут m. входные данные: на вход программе подается целое число d (0< =d< =360 выходные данные: выведите на экран фразу: it is hours minutes. на языке паскаль.

Информатика

Ответы

topsalon
Var d,time,hours,min:integer;
begin
  readln(d);
  time:=d*120;
  hours:=time div 3600;
  min:=time mod 3600 div 60;
  writeln('it is ',hours,' hours ',min,' minutes');
end.
inbox466
Символ-это набор команд состоящих из единиц и нулей,любое слово вводимое тобой или выведонное тебе состоит из этих последовательностей. Например символ I (Я) зашифрован так 0100 1001 <-- 8 этих битов образуют 1 символ,называемым байтом,поэтому любой текст,изображение,видео(там немного другая схема действует),все это всего лишь грандиозный набор команд,разговоры по телефону тоже кодируются из вибрации в набор импульсов и на обратном выходе опять преобразуются в нам всем привычные слова.Любые механизмы,и даже мы с Вами можем передавать информацию,в том числе Азбукой Морзе,даже несколько последовательно сформулированных щелчков пальцев несут в себе информацию,главное ее понять,расшифровать и преобразовать,в видео,аудио,текст,фотографию.
Dmitrii836
8
Укажите тип переменной для выражения: ((х>=-2) и (x<=2))
Если х, то
A. целый
B. вещественный
Если все выражение то
D. логический

9
Для выражения y=(3a+b)/2 исходными данными будут...
A. a,b

10
Для выражения y=(a+4b) при а=6, b=8 результат будет равен...
D. 38

11
Неправильным является имя величины...
C. 12авс

12
Сумма двух слагаемых а и b, деленная на сумму двух других
слагаемых c и d запишется как...
C. (a+b)/(c+d)

13
Имеется серия команд
f:=2;
f:=f*f;
f:=f*f;
f:=f*f.
Чему равен результат?
B. 256

14
Линейным называется алгоритм, в котором...
A. команды выполняются одна за другой в порядке их следования

15
Строка:
readln (A);
выполняет...
A. ввод в программу значения переменной А

16
Y:=5;
какой оператор выведет надпись Y=5?
A. writeln ( ' Y = ' , Y ) ;

17
а:=2; b:=8;
S:=а+b;
После выполненных последовательно данных трех команд переменная S принимает значение
равное ...
A. 10

18
S:=7;
S:=23;
writeln (S);
Какое значение будет выведено на экран?
A. 23

19
S:=1;
S:=S+5:
Writeln (S/2);
Что будет выведено на экране?
A. 3

20
A:=2; B:=5: B:=B-A; S:=A+B;
writeln (S);
Что будет выведено на экран?
A. 5

21
Для ввода данных в блок-схемах используют фигуру...
A. параллелограмм

22
Для выполнения вычислительных действий в блок-схемах используют фигуру...
C. прямоугольник

23
Определите результат работы фрагмента программы:
writeln ( ' 5+5= ' , 5+5 );
A. 5+5=10

24
Действие оператора WRITELN - это...
A. переход на новую строку

25
Сколько переменных нужно ввести для вычисления площади и периметра квадрата?
A. одну

26
Найдите логически неверно записанную последовательность команд.
те что имеют непонятные логические ходы
A. writeln (S); A:=A*2; readln (A,B); S:=A+B;
C. A:=A*2; readln (A,B); S:=A+B; Writeln (S);
D. readln (A,B); S:=A+B; A:=A*2; writeln (S);
27
Как будут выведены значения:
Writeln (A); Writeln (B); ?
A. в столбик

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Часовая стрелка повернулась с начала суток на d градусов. определите, сколько сейчас целых часов h и целых минут m. входные данные: на вход программе подается целое число d (0< =d< =360 выходные данные: выведите на экран фразу: it is hours minutes. на языке паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marinarodina90
Sokolova-Shcherbakov
Шавкат кызы
nadejdashin508
mail5
ckati
Voronov434
kuharhuks
Нана_Елена
Вакуленко
ribcage52
Домрачев
dimkimka386
asviridova07194
orgot9