Стяжкин
?>

Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.

Информатика

Ответы

Белов_Лукина1339
Var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
Dms161964937
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  for var i:=100 to 999 do begin
    var d1:=i div 100;
    var d2:=(i div 10) mod 10;
    var d3:=i mod 10;
    if sqr(d1)=d2+d3 then Print(i)
    end;
  Println
end.

Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
arch5050

Відповідь:

Дивись фото

Пояснення:

<!DOCTYPE html>

<html>

<head>

  <title>Price</title>

  <meta charset="utf-8">

</head>

<body>

 <p>стоимости переговоров</p>

</body>

<script>

 {/*Написать логическое выражение для определения стоимости переговоров, если стоимость переговоров с 22 часов до 8 часов на 20% ниже, а в субботу и в воскресенье дополнительно предоставляется скидка 10%. */}

 t = +prompt('время разговоров от 0 до 24 часов')

 dt = +prompt('продолжительность разговора в минутах')

s = +prompt('стоимость минуты разговора')

 d = +prompt('день недели от 1 до 7')

 console.log('t=',t,'dt=', dt, 's=', s, 'd=', d)

 function Price (t, dt, d, s) {

  let startTalk = t*60

  let price = 0

  console.log('day = ', d)

 

  for (let i =1; i<=dt; i++){

   let night = false

   let holiday = false

   let p = s

   

   if( (startTalk+i)%1440 === 0 ){

    if (d<7){

     d=d+1

     console.log('day = ', d)

    } else {

     d=1

     console.log('day = ', d)

    }

   }

   if ( (startTalk+i)%1440>=1320 || (startTalk+i)%1440<480){

    night = true

   }

   if ( d === 6 || d===7){

    holiday = true

   }

   if (night){

    p = p - s*0.2

   

   }

   if (holiday){

    p = p-s*0.1

   }

   price = price+p

   

   console.log('стоимости '+ i+'мин. = '+ p.toFixed(2)+'$')

  }

  console.log('fin.price', price.toFixed(2), '$')

  return price.toFixed(2)

 }

 {/*Price(t, dt, d, s)*/}

 alert('стоимости переговоров  ' + '$' + Price(t, dt, d, s))

</script>

</html>


Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
chuykin
<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title></title>
</head>
<body bgcolor=lightgrey>
<font color=red face="Arial"><h1 align=center>Иванов</h1>
<h2 align=center>Иван Иванович</h2>
</font>
<hr width=50%>
<a href="document2.html">На страницу 2</a>
</body>
</html>

<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title></title>
</head>
<body bgcolor=lightgrey>
<font color=blue face="Arial"><h1 align=center>Иванов</h1>
<h2 align=center>Иван Иванович</h2>
</font>
<hr width=50%>
<font face="Times New Roman">
<ul>
Список группы:
<li> Чел1
<li> Чел2
<li> Чел3
<li> Чел4
<li> Чел5
<li> Чел6
</ul>
<ul type=square>
Список отсутствующих:
<li> Чел1
<li> Чел2
<li> Чел3
</ul>
</body>
</html>

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Liliya_Ivanova
Демидова Красноцветов
Demina-Khokhlov584
nord0764
zharovaleks
dvbbdv4
Дмитрий74
Zebra198383
morozovalexander90
Kotvitskii
Komarovsergeysk
nickname0091
fedotochkin8
myatadinamo
bellatrixstudio