Смирнов_Андрей691
?>

Вывести элементы массива значения которых меньше их индекса. составить программу (паскаль), оформить ответ!

Информатика

Ответы

петрАфанасьев
Var  a: array[1..10] of integer;  i: integer;
begin 
Writeln('Массив '); 
for i := 1 to 10 do  begin   
  a[i] := random(10);   
  write(a[i], ' '); 
end; 
Writeln; 
writeln('Числа и их индекс (по условию)'); 
for i := 1 to 10 do   
if i > a[i] then write('(', a[i], ' - ', i, ') ');
end.
sochi-expert
У меня получилось вот что (смотри скриншоты листинга программы и результата работы этой программы):
uses Crt;
const n = 10;
var A: array [1..n] of integer; 
        i: integer;
begin 
ClrScr; 
Randomize; 
WriteLn ( ' Massiv I: '); 
for i:=1 to n do 
    begin     
          A[i] := 1+random(n);  
          Write (A[i]:4); 
    end; 
WriteLn; WriteLn ( ' Massiv II: '); 
for i:=1 to n do 
    begin   
           if (A[i] mod 2 =0) then A[i]:=0 else A[i]:=3*A[i];     
           Write (A[i]:4); 
   end;
ReadLn;
end.     
Составьте программу, которая запол няет массив a [1..10] случайными целыми числа ми в диапазоне от 1
Составьте программу, которая запол няет массив a [1..10] случайными целыми числа ми в диапазоне от 1
Lesya
Program q1;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of integer;
countNum:integer; // переменная для хранения количества нечетных чисел
proizv:integer; // переменная для хранения произведения нечетных чисел
BEGIN
proizv:=1; // так как, изначально равно 0, а при умножении на 0 будет всегда 0
{создание последовательности n целых чисел}
Writeln('Случайные целые числа: ');
for i:=1 to n do
begin
mass[ i ]:=random(9)+1; //присваеваем переменной случайное значение от 1 до 10
write(inttostr(mass[ i ])+', ');
end;
{Вычисление произведения и количества нечетных чисел}
for i:=1 to n do
if mass[ i ] mod 2 <> 0 then //проверяем не четное-ли число, если да, то.. .
begin
inc(countNum); //увеличиваем на один кол-во нечетных чисел
proizv:=proizv*mass[ i ]; // высчитываем произведение
end;
{Вывод результатов}
writeln;
writeln('Всего нечетных чисел: '+inttostr(countNum));
writeln('Их произведение: '+inttostr(proizv));
END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вывести элементы массива значения которых меньше их индекса. составить программу (паскаль), оформить ответ!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Butsan-Bagramyan
Баринова
Bondarev_Ayupova795
steff77
alanatan5757
archala
ilkindadashov935232
Роман_Гречина
tyrnaus
Юрьевич293
ElenaEgorova1988576
Valerii276
Хрулёва
Peshkov
modno-trikotazh
▲