16,13(10 с/с)->(16 c/c) =10.2147АЕ147АЕ1000
целую и дробную часть переводим отдельно
ЦЕЛАЯ ЧАСТЬ = 10
16 | 16
16 | 10 <
|
0 - остаток 0 сносим в частное--
ДРОБНАЯ ЧАСТЬ
умножаем основание на основание 16 - постоянно
0.13
*16
2.08 - целую часть (запоминаем) - дробную снова умножаем на 16
0.08
*16
1.28 - целую часть (запоминаем) - дробную снова умножаем на 16
0.28
*16
4.48- целую часть (запоминаем) - дробную снова умножаем на 16
0. 48
*16
7,68- целую часть (запоминаем) - дробную снова умножаем на 16
0,68
*16
и так далее
из целых частей от умножения (2 1 4 7 )- формируется ДРОБНАЯ часть шестнадцатиричного числа
соединяем с ЦЕЛОЙ частью - получается бесконечная шестнадцатиричная дробь
10.2147АЕ147АЕ1000
(16 c/c)->(10 c/c) - обратная операция
Для перевода шестнадцатеричного числа в десятичное необходимо это число представить в виде суммы произведений степеней основания шестнадцатеричной системы счисления на соответствующие цифры в разрядах шестнадцатеричного числа.
10.2147АЕ =1*16^1+0*16^0+2*16^-1+1*16^-2+4*16^-3+7*16^-4+10*16^-5+14*16^-6 =16.12999999523163=16.13
const
n = 10; //количество элементов массива
var
a: array [1..n] of real;
i: integer;
begin
for i:= 1 to n do
begin
writeln('Введите ', i, ' элемент массива');
readln(a[i]); //вводим очередной элемент массива
end;
write('Исходный массив: ');
for i:= 1 to n do
write(a[i], ' '); //Выводим исходный массив
writeln; //Перевод на новую строку
write('Полученный массив: ');
for i:= 1 to n do
begin
a[i]:= a[i] * a[n]; //элемент массива умножаем на последний элемент
write(a[i], ' '); //выводим полученный элемент массива
end;
end.
Поделитесь своими знаниями, ответьте на вопрос:
8класс. составить программу для вывода на экран таблицы соответствия между дюймами и сантиметрами для значений от 11 до 22 дюймов.
Var
i:integer;
begin
for i:=11 to 22 do
writeln(i,' ',i*2.54);
end.