Ахади
?>

Сна языке питон 3 : последовательность состоит из натуральных чисел и завершается числом 0. определите значение наибольшего элемента последовательности.

Информатика

Ответы

gudachaa1480
В Python нет цикла похожего на Repeat ... Until в Pascal. Поэтому обойдемся циклом while:

a = int(input())
max =a
while a!=0:
    a = int(input(a))
    if a > max:
      max = a
print (max)
Некрасова-И

program raf105;

var

 a,i,j,s: integer;

 f,st: string;

 inA,inB: boolean;

begin

 readln(a);

 readln(f);

 i:=1;

 while i < length(f)-1 do

   begin

     st:= f[i] + f[i+1];

     inA:= False;

     inB:= False;

     for j:=1 to length(st)-1 do

       begin

         if st[j] = 'a' then inA:= True;

         if st[j] = 'b' then inB:= True;

       end;

     if (not inA) or (not inB) then

       if st = 'bb' then

         f[i+1]:= 'a'

       else

         f[i+1]:= 'b';

       s:= s+1;

     i+= 2;

   end;

 writeln(s);

 for i:=1 to length(f)-1 do

   write(f[i],' ');

end.

PascalABC
vadimpopov88
Дано Разрешающая сканера 600 х 600 dpi. Размер 10см х 15см. Глубина Цвета 3 байта. Найти: Каков информационный объем этого файла? Решение Вначале переводим глубину цвета из байт в биты 3 байта 8биТв байте 24 бит вычисляем разрешение сканера в 1 дюйме квадрат 600600 360 000 пикселей в 1 дюйм Переводим размер картинки из квадратов Сантиметров в Квадратные дюймы 10см 3.937дюйма 15см 5,906 дюйма 1015-150 смл2-3,937 5 906 23,25 дюйм Вычисляем в разрезе 23,25 дюймл2 360 000 пикселей в 1 дюйм 2E 8 370 000 пикселей Информационный объем вычисляем по формуле КОЛИЧЕСТВО ПИКСелей глубину цвета 8 370 000 пикселей 24 биTE 200 880 000 бит. lереводим в бай Ты делением На 8 25 110 000 байт или же делим на 10241024 чтобы получить количество мегабайт 23,95 мегабайт ответ: Информационный объем отсканированного изображения или 23,95 Мегабайт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сна языке питон 3 : последовательность состоит из натуральных чисел и завершается числом 0. определите значение наибольшего элемента последовательности.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Andreevna_Grebenshchikova155
tolyan791
elenachuxina804
MikhailNechaeva
akakne86
NatalyaAlekseevich1644
gusrva3001
sveta300856729
Vrezh
Надья-Олеговна
TatyanaVladimirovich
kadrevproduction
Vasilevna_Mikhail19
skrepka397412
sergei-pletenev