info2
?>

Вводится количество занятий (часов) по предмету и количество пропущенных занятий. вычислить процент посещаемости. составьте программу паскаль

Информатика

Ответы

droshchupkin
Program progul ;
var total , lost , visit : real ;
begin
 write ('vvedite vsego zaniatii Total=' ) ;
  readln ( total ) ;
 write ( 'vvedite Propuskov =' ) ;
  readln ( lost ) ;
  visit := (total - lost ) / total * 100 ;
  writeln ( 'procent poseshaemosti=' , visit:5:2 , '%' ) ;
end.
sbraginets
Вроде должна работать это 1 задача

uses crt;
var a,i,j,n:integer;
begin
writeln('ВВедите кол. конфет в (кг)');
read(a);
n:=0;
if a>=10 then begin n:=n+ a div 10; a:=a-(a div 10*10); end;
if (a>=5) and (a<10) then begin n:=n+ a div 5; a:=a-(a div 5*5); end;
if (a>=1) and (a<5) and (a<10) then begin n:=n+ a div 1; a:=a-(a div 1*1); end;
writeln('Общее количество коробок = ',n);
end.

2 задача
uses crt;
var a,i,j,n:integer;
begin
writeln('Введите кол. суток');
read(a);
writeln('Количество часов в ',a,' сутках = ',a*24);
writeln('Количество минут в ',a,' сутках = ',a*24*60);
writeln('Количество секунд в ',a,' сутках = ',a*24*60*60);
end.
Olegmgu11986
Uses Crt;
Var
   A,B:integer;
   P:real;
   C:boolean;
Begin
ClrScr;
Write('Введите натуральное число: ');ReadLn(B);
Write('A = ');ReadLn(A);
P:=1;
C:=false;
B:=Abs(B);
While B>0 do
   Begin
   P:=P*(B mod 10);
   if B mod 10 = A then C:=true;
   B:=B div 10
   End;
WriteLn('P = ',P);
if C then WriteLn('Не верно')
else WriteLn('Верно');
ReadLn
End.

uses Crt;
Var
   A:integer;
Begin
ClrScr;
For A:= 100 to 999 do
    if ((A+1) mod 2 = 0)and((A+2) mod 3 = 0)and((A+3) mod 4 = 0)and((A+4) mod 5 = 0) then Write(A,' ');
ReadLn;
End.

uses Crt;
Var
   A,B,C:integer;
Begin
ClrScr;
Write('Введите натуральное число: ');ReadLn(B);
Write('A = ');ReadLn(A);
C:=0;
While B<>0 do
   Begin
   if B mod 10 <> A then C:=C*10+B mod 10;
   B:=B div 10;
   End;
While C<>0 do
   Begin
   B:=B*10+C mod 10;
   C:=C div 10
   End;
WriteLn(B);
ReadLn;
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вводится количество занятий (часов) по предмету и количество пропущенных занятий. вычислить процент посещаемости. составьте программу паскаль
Ваше имя (никнейм)*
Email*
Комментарий*