kiruha0378
?>

Написать программу в паскале вычислить значения функции y=tg(sinx)+2 при x=0, 5; 0, 7; 0, 9; …; 2, 1.

Информатика

Ответы

Федоровна-Васильева
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var x:=0.5;
  while x<=2.1 do begin
    Writeln('x=',x:3:1,' y=',tan(sin(x))+2);
    x+=0.2
    end
end.

Результат выполнения программы
x=0.5 y=2.5198809015013
x=0.7 y=2.75112025607465
x=0.9 y=2.99586604900996
x=1.1 y=3.23765167169871
x=1.3 y=3.43923041043966
x=1.5 y=3.5488600833871
x=1.7 y=3.52922062804747
x=1.9 y=3.38750383103094
x=2.1 y=3.16912357769899
AnvarzhonovichNadezhda1071

Номер 1

использовать Робот

алг

нач

нц пока сверху свободно

вверх

кц

нц пока сверху стена

закрасить

влево

кц

нц пока сверху не стена

влево

кц

нц пока сверху стена

закрасить

влево

кц

вверх

вправо

нц пока снизу стена

закрасить

вправо

кц

нц пока снизу не стена

вправо

кц

нц пока снизу стена

закрасить

вправо

кц

кон

Номер 2

использовать Робот

алг

нач

нц пока сверху стена

закрасить

влево

кц

вправо

нц пока сверху стена

если справа не свободно то

вправо

все

если справа свободно то

вправо

если сверху стена то

закрасить

все

все

кц

влево

нц пока снизу не стена

вниз

кц

нц пока слева не стена и снизу стена

закрасить

влево

кц

кон

larson96

Консольные программы — это наследие старых операционных систем типа MS DOS, работавших в текстовом режиме. Полной аналогии здесь нет, но создатели систем разработки пытаются сделать всё, чтобы было максимальное сходство. Для консольной программы операционная система или система разработки предоставляет специальное окно (обычно — черного цвета), в котором виден ход выполнения программы.

Оконное приложение всегда имеет своё собственное окно (обычно его называют главным окном приложения). Кроме главного окна в приложении могут использоваться множество других окон.

При разработке оконного приложения используются различные элементы управления: командные кнопки, окна ввода, надписи, меню и т.д.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале вычислить значения функции y=tg(sinx)+2 при x=0, 5; 0, 7; 0, 9; …; 2, 1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gon4arovanat6
krasilnikov74
konss2
d892644813661946
Arsen0708
Наталья Юрьевич1228
Lidburg
Logukate
Emasterova77
Solovetzmila
Mexx9050
billl24
zabava-83
snk7777202
tokarevmax