Сергеевна-Пузанов
?>

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом. строка вводится с клавиатуры

Информатика

Ответы

Самохвалова-Геннадьевна
Var s:string;
begin
  readln(s);
  writeln(pos(' ',s));
end.

Тестовое решение:
Всем привет!
5
Usynin-nikolay
1.
const n=10;
var a:array[1..n] of integer;
max,min,i:integer;
begin
Randomize;
for i:=1 to n do begin
 a[i]:=random(51);
 write(a[i],' ');
 end;
writeln;
max:=a[1]; min:=a[1];
for i:=2 to n do
 begin
 if a[i]>max then max:=a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('max = ',max,'  min = ',min);
writeln(max,' + ',min,' = ',max+min);
end.

Пример:
42 24 9 46 9 47 24 24 29 39 
max = 47  min = 9
47 + 9 = 56

2.
begin
  var a:=ReadArrReal('Вводите массив:',10);
  Writeln('Max = ',a.Max);
  Writeln('Min = ',a.Min);
  Writeln('Max+Min = ',a.Max+a.Min);
end.

Пример:
Вводите массив: 15 23 85 46 70 38 94 43 51 76
Max = 94
Min = 15
Max+Min = 109
bessalaias
Ваня не учится в 35 школе, значит, либо в "47" либо в "52". Витя не учится в 47 школе, значит, либо "35" либо "52". Вите не нравится играть в шахматы, значит, либо "баскетбол" либо "футбол". Витя не учится в 47 школе, значит, он не играет в баскетбол, по условию сказано, что мальчик не играет и в шахматы, значит, Витя играет в футбол. По условию сказано, что ученик 35 школы не ходит в футбольную секцию, значит, Витя учится в 52 школе. Если не Ваня не Витя не учатся в 35 школе, значит, в этой школе учится Петя. Если Петя учится в 35 школе, а Витя в 52, то Ваня учится 47 школе. По условию сказано, что ученик 47 школы занимается баскетболом, значит, Ваня ходит в данную секцию. Если Витя ходит в футбольную секцию, а Ваня в баскетбольную, значит, в шахматную секцию ходит Петя.

ответ: 
- Петя учится в 35 школе и ходит в шахматную секцию
- Ваня учится в 47 школе и ходит в баскетбольную секцию
- Витя учится в 52 школе и ходит в футбольную секцию

Три друга петя, ваня и витя учатся в разных школах: 35, 47 и 52. все друзья занимаются в разных спор

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом. строка вводится с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*