fucksyara
?>

Уровень a. натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. например, 252 = 625. напишите программу, которая получает натуральное число n и выводит на экран все автоморфные числа, не превосходящие n. пример: введите n: 1000 1*1=1 5*5=25 6*6=36 25*25=625 76*76=5776

Информатика

Ответы

yahottabych201379
Var n,i,l:integer; s1,s2:string; 
begin
write('n = '); readln(n);
for i:=1 to n do
 begin
 str(i,s1);  l:=length(s1);
 str(i*i,s2);
 if s1=copy(s2,length(s2)-l+1,l) then writeln(i,'*',i,'=',i*i);
 end;
end.

n = 1000
1*1=1
5*5=25
6*6=36
25*25=625
76*76=5776
376*376=141376
625*625=390625
Anait_Natalya451
0 или 1битбайтб8 биткилобиткбит (кб)1 000 биткилобайткбайт (kб)1024 байтамегабитмбит (мб)1 000 килобитмегабайтмбайт (мб)1024 килобайтагигабитгбит (гб)1 000 мегабитгигабайтгбайт (гб)1024 мегабайтатерабиттбит (тб)1 000 гигабиттерабайттбайт (тб)1024 гигабайта

байт (byte) — единица хранения и обработки цифровой информации. чаще всего байт считается равным восьми битам, в этом случае он может принимать одно из 256 (2′8) различных значений. для того, чтобы подчеркнуть, что имеется в виду восьмибитный байт, в описании сетевых протоколов используется термин «октет» (лат. octet).

килобайт (кб, кбайт, кб) м., скл. — единица измерения количества информации, равная в зависимости от контекста 1000 или 1024 (2′10) стандартным (8-битным) байтам. применяется для указания объёма памяти в различных электронных устройствах. 1 килобайт (кб) = 8 килобит (кб)

мегабайт (мбайт, м, мб) м., скл. — единица измерения количества информации, равная, в зависимости от контекста, 1 000 000 (10′6) или 1 048 576 (2′20) стандартным (8-битным) байтам.

гигабайт (гбайт, г, гб) — кратная единица измерения количества информации, равная 2′30 стандартным (8-битным) байтам или 1024 мегабайтам. применяется для указания объёма памяти в различных электронных устройствах.

терабайт (тбайт, тб) м., скл. — единица измерения количества информации, равная 1 099 511 627 776 (2′40) стандартным (8-битным) байтам или 1024 гигабайтам. применяется для указания объёма памяти в различных электронных устройствах.

петабайт (пбайт, пб) м., скл. — единица измерения количества информации, равная 25′0 стандартным (8-битным) байтам или 1024 терабайтам. применяется для указания объёма памяти в различных электронных устройствах.

эксабайт (эбайт, э, эб) — единица измерения количества информации, равная 26′0 стандартным (8-битным) байтам или 1024 петабайтам. применяется для указания объёма памяти в различных электронных устройствах.

зеттабайт (збайт, з, зб) — единица измерения количества информации, равная 27′0 стандартным (8-битным) байтам или 1024 эксабайтам. применяется для указания объёма памяти в различных электронных устройствах.

йоттабайт (йбайт, й, йб) — единица измерения количества информации, равная 1024 стандартным (8-битным) байтам или 1000 зеттабайтам. применяется для указания объёма памяти в различных электронных устройствах.

1 йoттабайт можно представить как:

103 = 1 000 зеттабайтов106 = 1 000 000 эксабайтов109 = 1 000 000 000 петабайтов1012 = 1 000 000 000 000 терабайтов1015 = 1 000 000 000 000 000 гигабайтов1018 = 1 000 000 000 000 000 000 мегабайтов1021 = 1 000 000 000 000 000 000 000 килобайтов

1024 = 1 000 000 000 000 000 000 000 000 байтов

slavutich-plus2
Комп'ютер это сложный организм за которым нужно присматривать и следить за компонентами в особенности за кулерами,непонятно почему именно за ними сечас обьясню.кулер охлаждает важние детали такие как блок питания,процесор,видео карта которые при нагреве могут воспламенится или припой может потечь и всей системе может прийти срок или может испортится блок питания который питает систему,процессор который обрабатывает информацию,видео карту которая выводит и обрабатывает видео сигналы.но нерекомендуется пользоватся водным охлаждением или в народе их называют водянками потому-что вода может потечь на детали и к короткому замыканию! и нужно иметь антивирусную програму для защиты данных.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Уровень a. натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. например, 252 = 625. напишите программу, которая получает натуральное число n и выводит на экран все автоморфные числа, не превосходящие n. пример: введите n: 1000 1*1=1 5*5=25 6*6=36 25*25=625 76*76=5776
Ваше имя (никнейм)*
Email*
Комментарий*