Varagyan1728
?>

На паскале. вводятся координаты x, y для n точек. определите, сколько точек в круг радиуса r. сколько точек в кольцо с меньшим радиусом r1, большим r2.

Информатика

Ответы

Роман Александр66
Var x,y,R,R1,R2,rt:real;i,N,k,m :integer;begin

R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N); 

for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);

if rt < R then k:= k + 1;

if (rt < R2) and (rt > R1) then m:= m + 1;

end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.
polotovsky
Линейка нужна для изменения расстояния (между точками) с незначительной погрешностью.
Транспортир нужен для измерения градусной меры угла с незначительной погрешностью.
Термометр нужен для измерения температуры.
Барометр нужен для измерения атмосферного давления.
Компас нужен для ориентирования по магнитным полюсам Земли.
Телескоп нужен для того, чтобы увидеть отдалённые объекты.
Микроскоп нужен для того, чтобы увидеть незримые невооружённым глазом тела.
Абак нужен для упрощения счёта.
Детектор Гейгера нужен для измерения радиационного фона.
=)
Марина555
Линейка - для измерения линейных размеров (длин, расстояний)
транспортир - для измерения плоских углов
термометр - для измерения температуры
барометр - для измерения давления
компас - для ориентирования по сторонам света (по азимуту) и для измерения азимутальных углов
телескоп - для наблюдения за макромиром, то есть за большими телами - небесной сферой (за звёздами, планетами и др., то есть за космосом)
микроскоп - для наблюдения за микромиром (то есть за маленькими телами)

курвиметр - для измерения длин криволинейных линий
динамомерт - для измерения сил
весы - для измерения массы
часы - для измерения времени

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На паскале. вводятся координаты x, y для n точек. определите, сколько точек в круг радиуса r. сколько точек в кольцо с меньшим радиусом r1, большим r2.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Korneeva1856
Larisaodinets5
rechkai64
krylova-natali
Merkuloff78
elenaftdv7
Mikhailova
verachus
a-lossev111
kovalenko262
elvini857
PetrovnaTsukanov
margarita25061961
natkoff5
Konstantinovna Ilyukhin1618