Составьте программу для нахождения количества дюймов d, которое содержится в x сантиметрах (1 дюйм = 2, 54 см исходное количество сантиметров задается с клавиатуры.
Следующее число, большее 125₁₀, равно 126₁₀ или 1111110₂ Посмотрим, может ли оно получиться по заданному алгоритму. На шаге 2а определяется "бит четности" путем подсчета количества единиц в двоичной записи числа. Если оно четно, к записи числа справа дописывается 0, если нечетно - единица. На шаге 2б повторяются действия предыдущего шага. Отбросим две правые цифры в записи 1111110₂ и посмотрим, как на получившемся числе работает предложенный алгоритм. 1111110 ⇒ 11111, число единиц нечетное, дописываем 1, получаем 111111, теперь число единиц четное, дописываем 0 и получаем 1111110, т.е. как раз то число, которое у нас было при переводе 126 в двоичную систему счисления. А исходное число - это 11111₂ = 31₁₀ ответ: 31
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу для нахождения количества дюймов d, которое содержится в x сантиметрах (1 дюйм = 2, 54 см исходное количество сантиметров задается с клавиатуры.
begin
read(x);
writeln(x/2,54);
end.