Таблица рецептов в БД
Пусть имеется проект в Simple-Scada и мы настроили подключение к СУБД MySQL к нашей базе данных с именем "my_database". Теперь в эту базу данных сохраняются сообщения, тренды проекта и т.д. Мы хотим добавить в БД новую таблицу для хранения рецептов и реализовать редактирование этой таблицы через скаду. Допустим у нас есть три компонента: K1, K2 и K3 и нужно чтобы при выборе рецепта количество каждого компонента считывалось из рецепта и записывалось в соответствующие переменные которые затем будут использованы в тех. процессе. Сначала организуем интерфейс проекта. Достаточно двух страниц.
x
2
+
y
2
=
16
...
...
...
...
...
...
.
.
(
1
)
x + y = 4 (2)
rearrange (2) to y = 4 - x (could do x = 4 - y )
substitute y = 4 - x into (1)
hence:
x
2
+
(
4
−
x
)
2
=
16
⇒
x
2
+
16
−
8
x
+
x
2
=
16
and
2
x
2
−
8
x
+
16
−
16
=
0
⇒
2
x
2
−
8
x
=
0
factor and solve : 2x(x - 4 ) = 0
⇒
x
=
0
,
x
=
4
substitute these values into y = 4 - x , to find corresponding values of y.
x = 0 : y = 4 - 0 = 4 → (0 , 4)
x = 4 : y = 4 - 4 = 0 → (4 , 0 )
These are the points of intersection with the line x +y = 4 and the circle
x
2
+
y
2
=
16
Answer link
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу вычисления значения выражения. (на языке паскаль) y=1/x-11, x> =0 x-35, x< 0 ! буду
x,y:integer;
begin
write('Введите значение x=');read(x);
if x>=0 then begin
writeln('Y=',1/x-11:5:2)
end;
if x<0 then begin
writeln('Y=',x-35);
end;
end.