Kozloff-ra20146795
?>

Напишите программу, которая сортирует отдельно элементы массива с чётными и нечётными значениями. все элементы с нечётными значениями нужно отсортировать по возрастанию, а элементы с чётными значениями – по убыванию. при этом элементы каждой из групп (как чётные, так и нечётные) должны занимать то же множество позиций в массиве, что и до сортировки. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 100000 . выходные данные программа должна вывести все элементы отсортированного массива в одну строку, разделив их пробелами.

Информатика

Ответы

Petrosienko_Larisa,1908
//Весьма слабое решение, но после перерыва мне простительно, хех.
//Pascal ABC.NET v3.1 сборка 1219

Var
 ar,arOdd,arNotOdd:array of integer;
 n,i,j,k1,k2:integer;
begin
 readln(n);
 setlength(ar,n+1);
 k1:=1;
 k2:=1;
 for i:=1 to n do
 begin
  readln(ar[i]);
  if odd(i) then
   begin
    setlength(arOdd,k1);
    arOdd[k1-1]:=ar[i];
    inc(k1);
   end
   else
   begin
    setlength(arNotOdd,k2);
    arNotOdd[k2-1]:=ar[i];
    inc(k2);
   end;
  end;
 sort(arOdd);
 sort(arNotOdd);
 reverse(arNotOdd);
 k1:=0;
 k2:=0;
 i:=0;
 while i<>n do
  begin
  inc(i);
   if odd(i) then
    begin
     ar[i]:=arOdd[k1];
     inc(k1);
    end
    else
    begin
     ar[i]:=arNotOdd[k2];
     inc(k2);
    end;
  write(ar[i],' ');
  end;
end.

Пример ввода:
5
1
2
3
4
5
Пример вывода:
1 4 3 2 5 
abuley
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.
tofilev

Объяснение:

1) #include <iostream>

using namespace std;

int main()

{

   int a, b;

   cout<<"Enter number 1";

   cin >> a;

   cout<<"Enter number 2";

   cin >> b;

   int res = a + b;

   cout << "Result - " << res << endl;

   return 0;

}

1.1) К целочисленному типу

1.2)2 входных значения

1.3)1 результат

1.4)(я не понимаю какие стрелки)

1.5)A + B = RES

2) #include <iostream>

using namespace std;

int main()

{

   float speed, time;

   cout<<"Enter speed";

   cin >> speed;

   cout<<"Enter time";

   cin >> time;

   int length = speed * time;

   cout << "Length- " << length << endl;

   return 0;

}

2.1) К дробному типу

2.2)2 входных значения

2.3)1 результат

2.4)(я не понимаю какие стрелки)

2.5)S = V * t

3. Слово Integer

4. можно: Vasya СУ-27 @mail_ru

                m11 Петя СУ_27 lenta.ru

                 m 1 Quo vadis СУ(27)

  нельзя: 1m Митин брат _27 "Pes barbos"

5. b!

6. в)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая сортирует отдельно элементы массива с чётными и нечётными значениями. все элементы с нечётными значениями нужно отсортировать по возрастанию, а элементы с чётными значениями – по убыванию. при этом элементы каждой из групп (как чётные, так и нечётные) должны занимать то же множество позиций в массиве, что и до сортировки. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 100000 . выходные данные программа должна вывести все элементы отсортированного массива в одну строку, разделив их пробелами.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

palchiknr
M19026789436
misstimarina2016
vitalina3012
tatasi
TrubnikovKlimenok926
gameover98
borvalmok432
fashbymsk
yda659
Valerevna Tuzova
Sergeevna803
shkola8gbr
alekseymedvedev1981
fellybrossme