Galinagol559
?>

Дан массив вещественных чисел x=(x1, записать элементы заданного массива х следующим образом: в начальной части расположить положительные элементы в порядке возрастания, затем в порядке убывания отрицательные элементы, нулевые элементы не записывать.

Информатика

Ответы

Irina
Решения на паскале(просто код и с пояснением).
LIN1022
Procedure TForm1.Button1Click(Sender: TObject);
var
  i1,i2,i3 : Integer;
  kk : Integer;
  Chislo : Integer;
begin
  Memo1.Clear;
  kk := 0;
  for i1 := 1 to 9 do
    for i2 := 0 to 9 do
      for i3 := 0 to 9 do
        if ( (i1<>i2) and (i1<>i3) and (i2<>i3) ) then
          if ( Frac((i1+i2+i3)/7)=0 ) then
          begin
            Chislo := i1*100 + i2*10 + i3;
            if ( Frac(Chislo/7)=0 ) then
            begin
               Memo1.Lines.Append(inttostr(Chislo));
               inc(kk);
            end;
          end;
end;


Написать программу на языке паскаль нахождения всех трехзначных чисел, у которых все цифры различны,
Михаил1121

#include

#include

#include

#include

#include

#include

typedef struct

{

char imya[40];

char familiya[40];

char otchestvo[40];

int telefon;

int texpasport;

float pages ;

}gor;

void form(char mass[10], char *imya, char *familiya, char *otchestvo, int telefon, int texpasport)

{

file *f;

gor y;

int i;

if ((f=fopen(mass,"w"))==null) exit(1);

for (i=1; i< =3; i++)

{

cout< < "vvedite imya: ";

cin> > imya;

cout< < "vvedite familiya: ";

cin> > familiya;

cout< < "vvedite otchestvo: ";

cin> > otchestvo;

cout< < "vvedite telefon: ";

cin> > telefon;

cout< < "vvedite texpasport: ";

cin> > texpasport;

fwrite(& y,sizeof(gor),1,f);

if(ferror(f)! =null)

exit(2);

}

fclose(f);

}

void vivod(char mass[50])

{

file *f;

gor z;

if ((f=fopen(mass, "r"))==null) exit(3);

cout< < "fail: "<

while (! feof(f)) {

fread (& z,sizeof(gor),1,f);

if (! feof(f))

{

cout< < "imya: "<

cout< < "familiya: "<

cout< < "otchestvo: "<

cout< < "telefon: "<

cout< < "texpasport: "<

}

fclose(f);

}

}

void del(char fo[10], char fi[10])

{

file *f1,*f2;

gor d;

//char temp[40];

if ((f1=fopen(fi,"r"))==null) exit(4);

if ((f2=fopen(fo,"w"))==null) exit(5);

//cout < < "vvedite nazvanie na ydalenie - ";

//cin > > temp;

for (int i=0; i< 3; i++)

{

fread(& d,sizeof(gor),1,f1);

if (feof(f1)) break;

if (i> 2)

fwrite (& d,sizeof(gor),1,f2);

}

fclose(f2);

fclose(f1);

}

void dobav(char fi[10], char fo[10],char *imya, char *familiya, char *otchestvo, int telefon, int texpasport)

{

int q;

int i;

gor d;

file *f1,*f2;

char temp[40];

if ((f1=fopen(fi, "r"))==null) exit(4);

if ((f2=fopen(fo,"r+"))==null) exit(5);

cout < < "vvedite familiu, pered kotorym nuzno dobavit element: ";

cin > > temp;

for (i=0; i< 10; i++)

{

fread(& d,sizeof(gor),1,f2);

if (feof(f2)) break;

if (strcmp(d.familiya, temp)) break;

q=i;

}

for (i=0; i< 10; i++)

{

if (feof(f2)) break;

fwrite (& d,sizeof(gor),1,f2);

if (i==q-1)

{

cout< < "vvedite imya: ";

cin> > imya;

cout< < "vvedite familiya: ";

cin> > familiya;

cout< < "vvedite otchestvo: ";

cin> > otchestvo;

cout< < "vvedite telefon: ";

cin> > telefon;

cout< < "vvedite texpasport: ";

cin> > texpasport;

cout <

}

}

fclose(f2);

fclose(f1);

}

void main()

{

int n=10;

//cout < < "vvedite kol-vo zapisey: - ";

//cin> > n;

//cout <

form("f1.txt",n);

vivod("f1.txt");

del("f1.txt","f2.txt");

cout < < "posle udalenia: \n";

vivod("f2.txt");

getch();

n=1;

system("cls");

dobav ("f2.txt","f2.txt");

cout < < "posle dobavlenia: \n";

vivod ("f2.txt");

getch();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив вещественных чисел x=(x1, записать элементы заданного массива х следующим образом: в начальной части расположить положительные элементы в порядке возрастания, затем в порядке убывания отрицательные элементы, нулевые элементы не записывать.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Рогов1996
sochi-expert
allo22-27
hristos1212
gk230650
ivanovk3599
lolydragon
starh
ElenaSkvortsova2
Freelifecool797
Константин Андрей
olgapotapova
qcrv15312
jurys71242
maksmi
▲