ответ: блок схема во вложении.
Объяснение:
1. заполняем массив А размерностью 20 целыми числами. устанавливаем начальное значение параметра цикла = 2, то есть цикл будет начинаться со 2-го элемента. устанавливаем флаг b в true. от нужен для проверки "на возрастаемость"
2. начинаем цикл со 2 до 20 элемента
3. если текущий элемент больше предыдущего, то делаем инкремент параметра i и переходим на повторение цикла.
4. если текущий элемент НЕ больше предыдущего, то сбрасываем флаг b и выходим из цикла. Условие возрастаемости нарушено, дальнейшее сканирование не имеет смысла.
5. проверка флага b: в том случае если весь цикл пройден, от равен true, иначе, если был совершен выход из цикла по причине п.4, то равен false
6. в зависимости от состояния флага b выводим соответствующее сообщение.
блок-схема может редактировать через сайт: https://www.draw.io
=С$5-$B3, проверяла в екселе
Объясния: если в екселе использовать значок $ то ми фиксируем или столбец или строку.
В нашем случае С$5 ми зафиксировали 5, а в $B3 ми зафиксировали В.
Наша формула стояла в клетке D5, а когда ми скопировали её в Е6. То в первой части формулы тоесть С$5 в формуле столбец с C передвинулся на D потому что мы его не фиксировали, а 5 так и осталось потому что оно зафиксированное. Тогда получилось D$5. А другая часть формулы то есть $В3 наоборот столбец В так и остался, а с 3 стала 4. И у нас получилось $В4. Все передвинулись только на одину букву и цифру потому что ми переместили формулу с D5 в E6 а кто на один столбец вправо и на одну цифру вниз.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на pascal, условие: даны три действительных числа. возвести в квадрат те из них, значения которых неотрицательны.
Begin
Readln(a,b,c);
if (a>0) then a:=a*a;
if (b>0) then b:=b*b;
if (c>0) then c:=c*c;
Writeln(a,' ',b,' ',c);
Readln(a);
end.