Karmelita1978
?>

Напишите программу, которая заменяет расширение у заданного имени файла. входные данные первая строка содержит имя файла, которое нужно изменить. во второй строке записано нужное расширение. выходные данные программа должна вывести изменённое имя файла с заданным расширением. примеры входные данные qwerty exe выходные данные qwerty.exe входные данные qwetry.old.pas html выходные данные qwetry.old.html

Информатика

Ответы

ValerevnaRustam1072
//Pascal ABC.NET v3.1 сборка 1219

Var
 s,sf:string;
begin
 readln(s);
 readln(sf);
 if pos('.',s)<>0 then
 delete(s,s.LastIndexOf('.')+2,length(s)-s.LastIndexOf('.'))
 else
 s+='.'; 
 writeln(concat(s,sf));
end.

Пример ввода:
point.simple.txt
pdf
Пример вывода:
point.simple.pdf
Хабарьева Андрей1056
Var
  arr: array[1..27] of integer;
  summ: integer;
begin
  Randomize;
  for var i := 1 to 27 do
  begin
    arr[i] := random(-5, 5);
    summ := summ + arr[i];
  end;
  writeln('Массив: ',arr);
  writeln('Сумма всех элементов массива = ',summ);
  for var i := 1 to 27 do if arr[i] = 0 then arr[i] := summ;
  writeln('Массив: ',arr);
end.

пример работы:
Массив: [5,-1,1,5,4,-2,-3,0,3,5,-3,-4,3,0,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]
Сумма всех элементов массива = 14
Массив: [5,-1,1,5,4,-2,-3,14,3,5,-3,-4,3,14,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]

var
  arr: array of integer;
  n,k,m: integer;
begin
  write('Введи n: ');
  readln(n);
  Randomize;
  arr:= new integer[n];
  for var i := 0 to n-1 do arr[i] := random(-5, 5);
  writeln('Массив: ',arr);
  for var i := 0 to n-1 do
  begin
    if arr[i]<0 then inc(k);
    if (i>=1) and (i<=6) then inc(m);
    if (i>=6) and (arr[i]>=0) then arr[i]:=1;
  end;
  writeln('Количество отрицательных элементов массива = ',k);
  writeln('Количество элементов массива в интервале [2..7] = ',m);
  writeln('Массив: ',arr);
end.

Пример работы:
Введи n: 5
Массив: [0,1,-4,1,3]
Количество отрицательных элементов массива = 1
Количество элементов массива в интервале [2..7] = 4
Массив: [0,1,-4,1,3]

Введи n: 15
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,3,1,-4,1,3]
Количество отрицательных элементов массива = 5
Количество элементов массива в интервале [2..7] = 6
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,1,1,-4,1,1]
ars-trushakova

Не на том сайте ты решил об этом попросить, но раз уж спросил то я постараюсь внятно ответить.

Тебе нужно вставить загрузочную флешку с любимым из windows, но лучше всего windows 7, загрузиться с неё, и дождаться когда появится кнопка "Установить". В самом низу у тебя будет "восстановления системы". Нажимаешь на неё, у тебя появиться окошко с двумя галочками. Выбиваешь первый и нажимаешь Далее, после чего выбираешь Командная строка, где вводишь такие команды

bootrec /fixmbr

bootrec /fixboot

И после этого перезагружаешь компьютер и всё должно работать. Если будут какие то вопросы можешь написать мне в лс, постараюсь

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая заменяет расширение у заданного имени файла. входные данные первая строка содержит имя файла, которое нужно изменить. во второй строке записано нужное расширение. выходные данные программа должна вывести изменённое имя файла с заданным расширением. примеры входные данные qwerty exe выходные данные qwerty.exe входные данные qwetry.old.pas html выходные данные qwetry.old.html
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annanas08
stic1995
zvezda-71
danceplusru
steam22-9940
Azarenkoff
emilbadalov
sanyaborisov910067
kush-2640
SERGEI124
office
mrilyushchenko6
aleksvasin
Nikolaevich1534
Елена-Семенова