Azarenkoff
?>

Составить программу к : с клавиатуры вводится два числа х и у. если х оканчивается на 4 , то вывести произведение х и у, иначе вывести сумму х и у.

Информатика

Ответы

n-896458

var x, y: integer;

begin

   readln(x, y);

   if x mod 10 = 4 then write(x * y)

   else write(x + y);

end.

mira15963256

1, 2, 3, 4

Объяснение:

Введем обозначения:

a = X > 0, b = X > 4

Тогда выражение будет иметь вид (a + b) → b и нужно найти условия, когда оно ложно. Вместо этого, мы будем искать, когда отрицание этого условия истинно, т.е. истинность ¬( (a + b) → b)

Для начала избавимся от импликации

¬( ¬(a + b) + b)

А теперь примерим к внешнему отрицанию закон де-Моргана

(a + b) · ¬b

Раскрываем скобки

a · ¬b  + b · ¬b

a · ¬b + 0

a · ¬b

Делаем обратную замену

( X > 0) · ¬(X > 4)

( X > 0) · (X ≤ 4)

Переведем это на более понятный язык:

X > 0 И X ≤ 4, или

0 < X ≤ 4

Из целых чисел сюда подойдут 1, 2, 3, 4.

teya07

1, 2, 3, 4

Объяснение:

Введем обозначения:

a = X > 0, b = X > 4

Тогда выражение будет иметь вид (a + b) → b и нужно найти условия, когда оно ложно. Вместо этого, мы будем искать, когда отрицание этого условия истинно, т.е. истинность ¬( (a + b) → b)

Для начала избавимся от импликации

¬( ¬(a + b) + b)

А теперь примерим к внешнему отрицанию закон де-Моргана

(a + b) · ¬b

Раскрываем скобки

a · ¬b  + b · ¬b

a · ¬b + 0

a · ¬b

Делаем обратную замену

( X > 0) · ¬(X > 4)

( X > 0) · (X ≤ 4)

Переведем это на более понятный язык:

X > 0 И X ≤ 4, или

0 < X ≤ 4

Из целых чисел сюда подойдут 1, 2, 3, 4.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу к : с клавиатуры вводится два числа х и у. если х оканчивается на 4 , то вывести произведение х и у, иначе вывести сумму х и у.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info7
armsam76
Максим_Нина
mmreznichenko
Arutyunovich
Оксана Анна
9999999999999999999999999​
Алиференко_Елена342
Guru-tailor
Narine natalya
dmitrymakarov003
сергеевич1958
and-syr
webotryvclub21
ГазалиеваКозак
sevro3038