byfetvostochniy
?>

Дан массив целых чисел (n=12), заполненный случайным образом числами из промежутка [-10, 60]. − удалить из него все элементы, в которых последняя цифра четная, а само число делится на нее.

Информатика

Ответы

Tipan77
//PascalABC.NET 3.1 сборка 1239
begin
    var a := ArrRandomInteger(12, -10, 60);
    a.Println;
    a.Where(x -> not ((x mod 2 = 0) and (x mod 10 <> 0) and (x mod (x mod 10) = 0))).Println;
end.
Dlyamila

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о


НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
lalaland2744

1) Что такое трассировка?

Трассировка - это процедура получения информации о маршрутизаторах (узлах), через которые проходят пакеты данных к интересующему компьютеру (серверу).

2) Какие виды трассировки вы знаете?

Основные объекты для трассировки. Все сооружения, коммуникации, для которых необходимо прокладывание трассы, делятся на два типа: Более требовательные к трассе и ее прямолинейности: каналы, железнодорожные и автомобильные магистрали, трубопроводы.

3) Какова роль Окна наблюдений и Точки

останова? В каком пункте меню они

расположены?

Точки останова — это один из важнейших инструментов разработчика для выполнения отладки. Точки останова устанавливаются везде, где нужно приостановить выполнение отладчика. Например, вы хотите просмотреть состояние переменных кода или стек вызовов в определенной точке останова. Если вы пытаетесь разрешить предупреждение или проблему при использовании точек останова, см. раздел Устранение неполадок точек останова в отладчике Visual Studio.

4) Объясните принцип выполнения алгоритма трассировки в визуальной среде выполнения

построения пользовательского интерфейса и упрощения разработки приложения путем замены метода "написания программы" на метод конструирования.

Объяснение:

только 4 есть

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив целых чисел (n=12), заполненный случайным образом числами из промежутка [-10, 60]. − удалить из него все элементы, в которых последняя цифра четная, а само число делится на нее.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Наталья_Владимир708
i7aster26
vovkiv7864
vet30
martabunova
pri02
ridyana504
ecocheminnov437
marimelons795
egornostaeva
Reutskii-Kirilovskii1625
zalev
Леонтьева
vedaikin
pechatlogo4