Anastasiya
?>

4.напишите программу , которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.программа получает на выход целые числа , количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность.)количество чисел не превышает 1000.введенные числа по модулю не превышают 30 000.программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

Информатика

Ответы

perovd8111
Var x,k: integer;   begin  k: =0;   repeat  writeln('введите число');   read(x);   if (x> 0) and (x< =256) then k: =k+1;   until x=0;   writeln('количество положительных чисел < =256 = ',k);   end.
Альберт Татьяна

c = 15   c = 2.00     c = 25              c = 9

c = 3    c = 1            c = 100             100

'qm'     c = ''   c = school2      error

Объяснение:

+ сложение(если строку str складывают с другой они просто скрепляются

// деление с выделением целой части

/ обычное деление чисел (происходит в формате float) даже если ответ целое число мы показывает десятые и сотые числа

% деление с выделением остатка

* умножение (если строка str умножается на целое число, то эта строка пишется несколько раз БЕЗ ПРОБЕЛА

** возведение в степень

max функция которая ищет максимум

строку на строку перемножать нельзя программа ложиться и выдаёт ошибку

zrs-546

Итак, целевой язык - C++. Это значит мы - радостные обладатели технологии потоков, с коей мы будем производить весь ввод/вывод как при работе с файлами, так и при работе со стандартным вводом/выводом (консолью).

Ну а раз уж мы работаем с потоками, то будем делать это красивенько: создадим класс-обёртку для потока ввода, цель которого - поиск в этом потоке цитат и отправка их на поток вывода (который мы передаём).

[!] Стоит отметить, что по заданию не сказано, что есть разница между ' и ". Поэтому будем считать их одинаковыми.

[!] Внимание! Рядом с исполняемым файлом надо создать текстовый файл data.txt c текстом и цитатами.

Код

С++11

#include <iostream>#include <fstream>using std::cout;class QuotesFinder {    std::istream &in_stream;    bool is_it_in_quote = false;public:    QuotesFinder() = delete;    QuotesFinder(QuotesFinder&&) = default;    QuotesFinder(QuotesFinder const&) = default;    explicit QuotesFinder(std::istream &is) : in_stream(is) {}    [[nodiscard]]    bool eof() const {        return in_stream.eof();    }    // Вот тут происходит вся магия    QuotesFinder& operator >> (std::ostream& out_stream) {        char buffer;        in_stream.get(buffer); //Получаем очередной символ из потока        if (buffer == '\"' || buffer == '\'') {            if (is_it_in_quote) {                is_it_in_quote = false;                out_stream << buffer;                out_stream << "\n";                return *this;            }            is_it_in_quote = true;        }        if (is_it_in_quote) {            out_stream << buffer;        }        return *this;    }};int main() {    std::ifstream file("data.txt");  // Открываем файл    if (!file.is_open()) {        cout << "File is not exits!";        return 1;    }    QuotesFinder finder(file);  // Создаём обёртку из файлового потока    while (!finder.eof()) // Пока не достигли конца потока        finder >> cout; // переправляем очередной кусок информации в поток вывода}
Написать программу на С++. Задача - Считать текст из файла и вывести на экран только цитаты, т. е. п

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

4.напишите программу , которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.программа получает на выход целые числа , количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность.)количество чисел не превышает 1000.введенные числа по модулю не превышают 30 000.программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ильдар-Кугай
Anna-Miron
kengyra
Karpova
tvtanya80
Можарова14
Bella Sergei
kbndbyb6
Зияева57
Светлана308
morozova4956
dentob72
morozovalexander90
kuzinnv1968
stepanova-natalie