katdavidova91
?>

Написать программу для паскаля: введите три числа (a, b, c найдите сумму чисел и если сумма больше 100, выдать соответствующее сообщение и сумму. (пример: сумма больше 100=258)

Информатика

Ответы

APerova3464
//Pascal ABC.NET v3.1 сборка 1219

Var
 a,b,c:integer;
begin
 read(a,b,c);
 if a+b+c>100 then writeln('Сумма больше 100=',a+b+c) else writeln('Сумма=',a+b+c);
end.

Пример ввода:
200
50
8
Пример вывода:
Сумма больше 100=258
platonovkosty
Program ff;vara,b,c,s:integer;begin readln(i,k,t);s:=a+b+c;begin if (s>100) then writeln ( 'сумма больше 100=', s)else writeln(s);end;end.
Aleksandrovna-Marina
1) Набираем 8ми литровый кувшин
2) отливаем 3 литра в 3х литровый и сливаем из него воду
3) в 8ми литровом осталось 5л воды, сливаем снова в 3х литровый, и в 8ми литровом осталось 2 литра воды.
4) выливаем из 3х литрового воду, и переливаем в него 2 литра, оставшиеся в 8литровом кувшине.
5)Снова наполняем 8ми литровый кувшин, и доливаем из него воду в 3х литровый кувшин, так как в 3х литровом налито 2 литра - там не хватает одного литра, значит отлив из 8ми литрового литр в нем останется 7 литров :)
И.Д.1065
В операторе y:=x*x+4/x+3 используется операция деления, которая всегда возвращает вещественный тип. Следовательно, и всё выражение в правой части всегда будет иметь вещественный тип. А в левой части стоит переменная целого типа. Присваивание вещественного значения целочисленной переменной запрещено правилами языка Паскаль.
Чтобы избавиться от ошибки, нужно знать алгоритм, который реализует программа. В зависимости от алгоритма может быть использована операция целочисленного деления, может быть использована функция Trunc(), возвращающая целочисленное значение аргумента, либо переменная y должна объявляться вещественной.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для паскаля: введите три числа (a, b, c найдите сумму чисел и если сумма больше 100, выдать соответствующее сообщение и сумму. (пример: сумма больше 100=258)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

moskvabelarus
fullhouse9991
Александровна-Павловна
frsergeysavenok
ylia89
R7981827791127
Boykoyelena
svt5299
ielienakozlova696
Dodkhobekovich1683
hr2251
Arsen-araqelyan20164
АндреевичАндрей
ГусенковФролова1121
MAXIM76748