ktatarinova
?>

Составьте программу для решения одной из следующих , которая запрашивает значение элементов одномерного числового массива а и подсчета суммы элементов массива, меньших своего номера.

Информатика

Ответы

werda84
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

Var
 a:array[1..n] of integer;
 i,s:integer;
begin
 for i:=1 to n do
  begin
   readln(a[i]);
   if a[i]<i then s:=s+a[i];
  end;
 writeln(s);
end.

Пример ввода:
2
2
1
1
2
Пример вывода:
4
cmdkotelniki

Жасанды интеллекттің мақсаты - есептемейтін мәселелерді шешуге және мағыналы ақпаратты өңдеуді қажет ететін және адам миының құзыреті болып саналатын әрекеттерді жасауға қабілетті техникалық жүйелерді құру. Мұндай мәселелерге, мысалы, проблемаларды дәлелдейтін теорема, ойын проблемалары (айталық, шахмат ойнағанда), бір тілден екінші тілге аудару, музыка құру, визуалды бейнелерді тану, ғылым мен қоғамдық практиканың күрделі шығармашылық мәселелерін шешу кіреді. Жасанды интеллекттің маңызды міндеттерінің бірі - адам мақсаттарына жету үшін операцияларды автономды түрде орындай алатын және олардың әрекеттеріне түзетулер енгізетін зияткерлік роботтар құру.

annanechaeva567

Географическая информация- это полная совокупность данных, нанесенных на бумагу, холст и т.д.

Слуховая информация- это информация которую мы слышим и запоминаем её (с ушей)

Текстовая информация- информация представленная в виде текста

Тактильная информация- чувствительная информация когда мы прикасаемся к чему либо пример: мы прикоснулись к горячему чайнику и убрали руку или кактусу)

Числовая информация - информация в виде чисел ( масса, расстояние и т.д.)

Зрительная информация- это информация которую мы видим с глаз (на книжке, на телефоне, телевизоре и т.д.)

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для решения одной из следующих , которая запрашивает значение элементов одномерного числового массива а и подсчета суммы элементов массива, меньших своего номера.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vkorz594
German
nadjasokolova2017
mausgaly
Platon
kulikovtsud
maksimovskiy7657
Васильевичь Виктория457
LIN1022
Половников1964
ladykalmikova81
bsi771184
aeykin
xcho1020
academycoffee243
▲