sirenashop25
?>

5-9 информатика написать программу в результате которой на экране появится диалог: - ! я - компьютер! а как тебя зовут? - мария - мария, 3 4 4 - ввод оценок - мария, твой средний по

Информатика

Ответы

polusik120796
Вторая:
#include <iostream>
using namespace std;
int main(){    setlocale(LC_ALL, "Russian");
    int form;    cin >> form;    string sForm[11] = {        "первоклассник","второклассник","третьеклассник","четвероклассник","пятиклассник",        "шестиклассник","семиклассник","восьмиклассник","девятиклассник","десятиклассник",        "одиннадцатиклассник"    };    cout << "Привет, " << sForm[form-1];    return 0;}

Первая:
Не совсем понятно условие - ввода для заполнения массива B нет. Поэтому пишу лишь основную часть кода.
int sum = 0;
for(int i=0;i<b-a;i++){
        C[i] = B[a+i];
        sum += B[a+i];
}

Третья:
#include <iostream>#include <cmath>
using namespace std;
int main(){    int x;    cin >> x;    double result[3];    result[0] = sin(x);    result[1] = cos(x);    result[2] = log(x);    bool finished = false;    while(!finished){        finished = true;        for(int i=0;i<2;i++){            if(result[i] < result[i+1]){                int buf = result[i];                result[i] = result[i+1];                result[i+1] = buf;                finished = false;            }        }    }    for(int i=0;i<3;i++){        if(result[i] == result[i] && abs(result[i]) != HUGE_VAL)        cout << result[i] << endl;    }    return 0;}

Примечание к коду: result[i] == result[i] - это проверка, является ли число неопределенным.
Сороченкова-Александр

Прикладной уровень OSI модели обеспечивает сопряжение человека с сетевыми технологиями, что позволяет пользователям общаться между собой через сеть. Другими словами, прикладной уровень создает интерфейс между приложениями конечных устройств при передаче сообщений по сети. Прикладной уровень представляет собой комплекс программных средств, представленных в двух формах: в виде приложений (applications) и программ служб сервиса (services).

Сопряжение человека с сетью обеспечивают приложения. Широко известны такие приложения этого уровня, как веб-браузеры гипертекстовой информационной службы (World Wide Web – WWW), которые позволяют людям готовить сообщения для передачи по сети и принимать такие сообщения. Наиболее известными веб-браузерами являются Internet Explorer, Mozilla Firefox, Opera.

Программы служб сервиса готовят данные для передачи по сети, обеспечивая эффективное использование ресурсов сети. Разные типы информации (аудио-, видео-, текстовая информация) требуют различных услуг, поскольку разнотипную информацию необходимо передать через общую сеть.

Протоколы прикладного уровня определяют правила обмена данными между узлом источником информации и узлом назначения. Каждый вид приложений и сервиса использует свои протоколы, которые определяют стандарты и форматы передаваемых данных.

Протоколы и службы прикладного уровня обычно представлены соответствующими серверами. Однако сервер, как отдельное устройство, может объединять функции нескольких служб сервиса; или наоборот, служба одного вида услуг может быть представлена многими серверами разного уровня.

Наиболее распространенными протоколами и службами прикладного уровня являются:

протоколы электронной почты (Simple Mail Transfer Protocol – SMTP, Post Office Protocol – POP, Internet Messaging Access Protocol – IMAP);протокол передачи гипертекстовой информации, или веб-сервер (Hypertext Transfer Protocol – HTTP);протокол передачи файлов (File Transfer Protocol – FTP) и простой протокол передачи файлов (Trivial FTP – TFTP);система доменных имен (Domain Name System – DNS);протоколы удаленного доступа (Telnet и SSH), обеспечивающие виртуальное соединение с удаленными сетевыми устройствами;протокол динамического назначения адресов узлов (Dynamic Host Configuration Protocol – DHCP).

Таким образом, приложения прикладного уровня обеспечивают интерфейс (сопряжение) человека с сетью. Службы сервисаиспользуют программные средства протоколов, чтобы подготовить информацию для передачи по сети.

Существуют две модели построения сети:

модель "клиент-сервер";модель соединения равноправных узлов сети (peer-to-peer).

В сети peer-to-peer связанные через сеть конечные узлы разделяют общие ресурсы (принтеры, файлы) без выделенного сервера. Каждое конечное устройство (peer) может функционировать либо как сервер, либо как клиент. Компьютер может выполнять роль сервера для одного соединения и роль клиента для другого.

Согласно модели "клиент-сервер" клиент запрашивает информацию, пересылая запрос выделенному серверу (upload), который в ответ на запрос посылает (download) файл, принимаемый клиентом. Следовательно, клиент инициирует процесс обмена информацией в среде "клиент-сервер" и получает от сервера требуемую информацию. Главным достоинством модели "клиент-сервер" является централизация управления сетью и обеспечение безопасности.

Ниже приведены краткие характеристики некоторых наиболее широко используемых протоколов прикладного уровня.

Протоколы передачи электронной почты

При передаче электронной почты и взаимодействии почтовых серверов между собой используется простой протокол передачи почты (Simple Mail Transfer Protocol – SMTP ), у которого номер порта 25. Для получения клиентом сообщения с сервера используется протокол почтового отделения (Post Office Protocol – POP ) с номером порта 110 или протокол доступа к сообщениям (Internet Messaging Access Protocol – IMAP ).

На рис. 2.1 приведена модель 'клиент-сервер' в службе электронной почты. При пересылке почты от клиента на сервер используется 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

5-9 информатика написать программу в результате которой на экране появится диалог: - ! я - компьютер! а как тебя зовут? - мария - мария, 3 4 4 - ввод оценок - мария, твой средний по
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

s777tver109
Pavlushina-Novikova
Олег86
lubavarif83
m-illarionov
YelenaZOLTANOVICh105
nataljatchetvertnova
Andreeva
Maly01984489
gilmore886173
Михеев557
татьяна1245
КристинаАлександр
ikosheleva215
zakup-r51