Написать программу на языке с++ уровень a. заполнить массив случайными числами и выполнить циклический сдвиг элементов массива вправо на 1 элемент. пример: массив: 1 2 3 4 5 6 результат: 6 1 2 3 4 5
#include <iostream> #include <cstdlib> #include <ctime> int main() { using namespace std; cout << "Enter size of array: "; int N; cin >> N; int * ARR = new int[N]; srand(time(0)); int i; for (i = 0; i < N; ++i) ARR[i] = rand() % 100 + 1;
cout << "Here is an original array:\n"; for (i = 0; i < N; ++i) cout << ARR[i] << " "; cout << endl;
int temp = ARR[N - 1]; for (i = N - 1; i > 0; --i) ARR[i] = ARR[i - 1]; ARR[0] = temp;
cout << "\nHere is a new array:\n"; for (i = 0; i < N; ++i) cout << ARR[i] << " "; cout << endl;
return 0; }
sveta300856729
13.06.2022
Правила: ¬(¬A)=A A→B=¬A∨B ¬(A∧B)=¬A∨¬B Преобразуем: ((J→K)→(M/\N/\L))/\((J/\¬K)→¬(M/\N/\L))/\(M→J)=1 ((¬J∨K)→(M∧N∧L))∧((¬J∨K)∨¬M∨¬N∨¬L)∧(¬M∨J)=1 (J∧¬K∨M∧N∧L)∧(¬J∨K∨¬M∨¬N∨¬L)∧(¬M∨J)=1 Начнем с J: Если J=0, то M обязательно должно быть 0(из-за последней скобки), НО тогда в первой не получится 1, значит, J=1. рассмотрим вариант с J=1. К равен 1 или 0. Если К=1, то в первой скобке получится единица только тогда, когда M,N,L будут равны единице. Это первый набор. Если К=0, то М равен 0 или 1. Если М равен 1, то N 1 или 0. Если N=1, то L=0, из-за второй скобки. Это второй набор. Если N=0, то L 1 или 0. Это 3 и 4 наборы. Если М равен 0, то N 1 или 0. Если N=1, то L 1 или 0. Это 5 и 6 наборы. Если N=0, то L 1 или 0. Это 7 и 8 наборы. ответ: 8
Strelkov567
13.06.2022
Когда нужно найти вероятность совершения некольких событий, происходящих друг за другом, вероятности каждого отдельного события перемножаются. Но когда нужна вероятность свершения хотя бы одного из событий, нужно найти вероятность того, что вся цепочка событий не произойдет и вычесть ее из единицы. Т.е. в данном случае мы сначала находим вероятность того, что нужное нам событие НЕ ПРОИЗОЙДЕТ.
Если из 44 краж раскрыто 14, то не раскрытых краж 44-14=30. Тогда вероятность, что первое взятое дело будет нераскрытым, составит 30/44 = 15/22. В этом случае у нас останется 43 кражи, 29 из которых нераскрыто и вероятность того, что второе выбранное дело будет нераскрытым, составит 29/43. Рассуждая аналогично, для третьего дела получаем 28/42 = 2/3. Вероятность, того что все три события будут иметь место, составит (15/22) х (29/43) х (2/3) ≈ 0.307. Следовательно, вероятность того, что этого не произойдет, т.е. наша искомая вероятность, составит 1-0.307 = 0.693. ,
#include <cstdlib>
#include <ctime>
int main()
{
using namespace std;
cout << "Enter size of array: ";
int N;
cin >> N;
int * ARR = new int[N];
srand(time(0));
int i;
for (i = 0; i < N; ++i)
ARR[i] = rand() % 100 + 1;
cout << "Here is an original array:\n";
for (i = 0; i < N; ++i)
cout << ARR[i] << " ";
cout << endl;
int temp = ARR[N - 1];
for (i = N - 1; i > 0; --i)
ARR[i] = ARR[i - 1];
ARR[0] = temp;
cout << "\nHere is a new array:\n";
for (i = 0; i < N; ++i)
cout << ARR[i] << " ";
cout << endl;
return 0;
}