pavelriga5
?>

Напишите программу, вычисляющую произведение двух чисел, вводимых с клавиатуры

Информатика

Ответы

cleopatra1959
#include < stdio.h> #include < time.h> int main(void)  {      int left, right, num = 5;       time_t t;       scanf ("%d %d", & left, & right);       if(left > = right)        {          fprintf(stderr, "min_num is greater or equal than max_num! \n");       }       printf ("left = %d right = %d \n", left, right);           /* intializes random number generator */    srand((unsigned) time(& t));       /* print num random numbers from left to right */       while (num > 0)       {        printf ( "%d ", left + (rand() % (right + 1 - left)) );         num--;       }       return 0; }
Imarmy67

унарная система счисления –  система счисления с основанием 1. используется, например, при подсчёте небольшого количества предметов: когда подсчитывается очередной предмет ставится единица (или зарубка, черточка, точка или любая другая отметка, также можно откладывать камешки, например). количество таких единиц совпадает с количеством предметов.

позиционная система счисления – система счисления, в которой значение цифры зависит от места, на котором она стоит. например, в десятичной системе стоимость цифры возрастает в 10 раз, если она сдвигается на одну позицию влево: 1 в записи числа 321 означает просто один, а в числе 213 – уже 10.

непозиционная система счисления – система счисления, в которой значение цифры не зависит от того места, на котором она стоит. обычно примером непозиционной системы счисления называют римские числа, хотя это не совсем верно: если цифра с меньшим номиналом стоит перед цифрой с большим номиналом, то её значение вычитается из большей цифры, например, xi = 11, но ix = 10 - 1 = 9. другие примеры – древнеегипетские числа, числа племён майя.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, вычисляющую произведение двух чисел, вводимых с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lenalevmax7937
Yelena_Yuliya1847
KononovaMaiorov453
ayk111560
ignashkinamasha
kifstd
Акимцева27
Gradus469
Vuka91
Тимур
Viktorovna
iralkap
yusliva
av4738046
MikhailovichKrizhnaya578