OOO"Kiprei"_Aleksandr1938
?>

Как такое решать? если можно по шагам ниже записаны две рекурсивные функции (процедуры): f и g. чему будет равно значение, вычисленное при выполнении вызова f(6)? паскаль python си f u n c t i o n f ( n : i n t e g e r ) : i n t e g e r ; b e g i n i f n > 2 t h e n f : = f ( n - 1 ) + g ( n - 2 ) e l s e f : = n ; e n d ; f u n c t i o n g ( n : i n t e g e r ) : i n t e g e r ; b e g i n i f n > 2 t h e n g : = g ( n - 1 ) + f ( n - 2 ) e l s e g : = n + 1 ; e n d ;

Информатика

Ответы

eliteclassic308
Анализ представленных функций можно сделать с таблицы (см. прилагаемый файл).
ответ: F(6)=17
Как такое решать? если можно по шагам ниже записаны две рекурсивные функции (процедуры): f и g. чему
Kondratchik Vladimir
// PascalABC.NET 3.2, сборка 1344 от 22.11.2016
// Внимание! В более ранних версиях программа работать не будет!
begin
  var d:=MatrRandom(4,4,-20,20);
  Writeln('Исходный массив'); d.Println(4);
  var s:=d[0,0];
  for var i:=1 to 3 do begin d[i,i]:=d[i,0]; s+=d[i,i] end;
  Writeln('Полученный массив'); d.Println(4);
  Writeln('Сумма на главной диагонали ',s)
end.

Пример
Исходный массив
  14   8 -12  12
  15  -9 -16  -6
  18  -7   7   5
  -7 -12 -10 -14
Полученный массив
  14   8 -12  12
  15  15 -16  -6
  18  -7  18   5
  -7 -12 -10  -7
Сумма на главной диагонали 40
cherkashenko87543

ответ:

подписывайся на меня

какую роль играет для меня информатика, информатика дает нам много информации что изучает что то новое каждый день много програм и приложений, роботов коды для роботов мы люди это эпоха гаджетов что праграмиравоны за счет информации, люди дает мнения а другие используя коменты новое информатика для нас как открытое знание. много в мире професий связанные с информатика если знать от а до я то тогда можно взламывать , создавать, пиидумавать, рисовать и т. д информатика это крутяк.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Как такое решать? если можно по шагам ниже записаны две рекурсивные функции (процедуры): f и g. чему будет равно значение, вычисленное при выполнении вызова f(6)? паскаль python си f u n c t i o n f ( n : i n t e g e r ) : i n t e g e r ; b e g i n i f n > 2 t h e n f : = f ( n - 1 ) + g ( n - 2 ) e l s e f : = n ; e n d ; f u n c t i o n g ( n : i n t e g e r ) : i n t e g e r ; b e g i n i f n > 2 t h e n g : = g ( n - 1 ) + f ( n - 2 ) e l s e g : = n + 1 ; e n d ;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

igor-790
tvmigunova551
rublevaoe392
smalltalkcoffee5
chysvv
ilukianienko458
amxvel7596
rb-zakaz
faberlic0168
tumanowivan2015509
orion-inginiring7807
Vlad Petr531
domtorgvl20082841
mansur071199486
Маринова