emaykova785
?>

Задан массив y с количеством элементов n. сформируйте массив, в котором элементы с четными индексами будут равны соответствующим элементам исходного массива, а элементы с нечетными индексами будут равны 0. надо. написать программу на языке паскаль*(

Информатика

Ответы

marketing6
Const n=10;
var y,z:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 y[i]:=random(51);
 write(y[i]:4);
 end;
writeln;
writeln('Полученный массив:');
for i:=1 to n do
 if i mod 2 = 0 then z[i]:=y[i] else z[i]:=0;
for i:=1 to n do write(z[i]:4);
writeln;
end.

Пример:
Исходный массив:
  16  22  48  16   9  33  27  42  40  24
Полученный массив:
   0  22   0  16   0  33   0  42   0  24
Fateevsa9
//Индексация с 0
//Pascal ABC.NET 3.1 сборка 1256

Const n=10;
Var
 i:integer;
 ar2:array[0..n-1] of integer;
begin
 var ar:=ArrRandomInteger(n,-10,10);
 writeln('Array Y:');
 ar.Println;
 for i:=0 to n-1 do
 ar2[i]:=0;
 for i:=0 to n-1 do
 if not(odd(i)) then ar2[i]:=ar[i];
 writeln('Final array:');
 ar2.Println;
end.
msk-academ
//Pascal ABC.NET v3.1 сборка 1219
Const 
n=15;

 Var
 ar:array[1..n] of integer; 
sum,i:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(2,23);
   write(ar[i]:4);
   sum:=sum+sqr(ar[i]);
  end;
 writeln;
 writeln('Sum=',sum);
 writeln('Final array:');
 for i:=1 to n do
  begin
   ar[i]:=ar[i]+ar[n];
   write(ar[i]:4);
  end;
end.

Пример работы программы:
First array:
  19  21  10  13   7  13   9   2  22  20  10   7  17   7  22
Sum=3229
Final array:
  41  43  32  35  29  35  31  24  44  42  32  29  39  29  44
irinakiral
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=15;

 Var
 ar:array[1..n] of integer;
 i,sum:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(5,15);
   write(ar[i]:4);
   if i<=6 then
   sum:=sum+ar[i];
  end;
 writeln;
 writeln('Sum=',sum);
 writeln('Final array:');
 for i:=1 to n do
  begin
   ar[i]:=ar[i]*7;
   write(ar[i]:6);
  end;
end.

Пример работы программы:
First array:
   9  15   5  12  13   6  11   7   6  14  13   6   6  10  11
Sum=60
Final array: 
   63   105    35    84    91    42    77    49    42    98    91    42    42    70    77

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан массив y с количеством элементов n. сформируйте массив, в котором элементы с четными индексами будут равны соответствующим элементам исходного массива, а элементы с нечетными индексами будут равны 0. надо. написать программу на языке паскаль*(
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Fomin Korablev1781
AMR89154331531
Ушакова1902
Бернард pokerman
Serdechnaya636
msk27
Александр Сергей
megapolisgroup
arevik2307
Nikita
tarkhanovilya
yusovd291
sedalex
yurazharov
ekrosenergoserv
▲