natachi
?>

Написать программу нахождения ymax , если задана функция: y = х2 – 100х + 10, где х изменяется от хнач. до хкон. с шагом с. программа должна так же выводить и значение х, при котором y принимает максимальное значение. значения хнач., хкон. и с должны задаваться пользователем при выполнении программы. для организации цикла воспользуйтесь оператором while.

Информатика

Ответы

BogdanR106203
Var 
x0,xn,c:real;
x,y,xmax,ymax:real;
begin
writeln('Xнач, Xкон:'); 
readln(x0,xn);
write('С = '); readln(c);
x:=x0;
xmax:=x; ymax:=x*x-100*x+10;
while x<xn do
 begin
 x:=x+c;
 y:=x*x-100*x+10;
 if y>ymax then begin xmax:=x; ymax:=y; end;
 end;
writeln('xmax = ',xmax,'  ymax = ',ymax);
end.

Пример:
Xнач, Xкон:
-10 20
С = 1
xmax = -10  ymax = 1110
kortikov77

1. Для того чтобы получить значение элемента из массива по индексу, необходимо обратиться к массиву с квадратных скобок: massive[индекс], где в скобках указывается местоположение элемента в массиве. Соответственно в аргументы функции необходимо передавать местоположение элемента. Выглядит это так:

public static int elementMassive(int i) {

return Main.massive[i];

}

2. Символьный массив или String, он объявляется не как все остальные массивы, а индетично объявлению других переменных. Объявление массива: int[] massive = new int[10];

Объявление переменной: int massive;

Как объявляется строка: String massive = "Hello";

Какой смысл (по сути) несет запись выше: char[] massive = new char[] {"H", "e", "l", "l", "o"};

3. Сравнивание строк equals, возращает true, если строка 1 равна строке 2

equalsIgnoreCase делает то же самое, что и первый метод, только без учета регистра

charAt возращает символ строки по индексу элемента

Так же есть методы повышения и понижения регистров.

4. Метод может передавать неограниченное количество значений, а вернуть всего 1

5. Формальные параметры — это идентификаторы входных данных для подпрограммы. Если формальные параметры получают конкретные значения, то они называются фактическими. Формальные параметры могут получить конкретные значения только в той программе, где производится обращение к данному модулю-подпрограмме. Тип и порядок записи фактических параметров должны быть такими же, как и формальных параметров. В противном случае результат работы программы будет непредсказуемым. Из этого следует, что фактические параметры используются при обращении к подпрограмме из основной, а формальные параметры — только в самом модуле.

6. Прототипы позволяют компилятору найти и сообщить информацию о всех незаконных преобразованиях типов между типами аргументов, используемых при вызове функции, и типами определенных параметров.

7. Перегрузка методов, одна из основ полиморфизма, заключается в том, что класс наследник реализует метод класса родителя с таким же названием, но с другим телом

jardi

Понятие кластеризации

Кластеризация (или кластерный анализ) — это задача разбиения множества объектов на группы, называемые кластерами. Внутри каждой группы должны оказаться «похожие» объекты, а объекты разных группы должны быть как можно более отличны. Главное отличие кластеризации от классификации состоит в том, что перечень групп четко не задан и определяется в процессе работы алгоритма.

Применение кластерного анализа в общем виде сводится к следующим этапам:

Отбор выборки объектов для кластеризации.

Определение множества переменных, по которым будут оцениваться объекты в выборке. При необходимости – нормализация значений переменных.

Вычисление значений меры сходства между объектами.

Применение метода кластерного анализа для создания групп сходных объектов (кластеров).

Представление результатов анализа.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу нахождения ymax , если задана функция: y = х2 – 100х + 10, где х изменяется от хнач. до хкон. с шагом с. программа должна так же выводить и значение х, при котором y принимает максимальное значение. значения хнач., хкон. и с должны задаваться пользователем при выполнении программы. для организации цикла воспользуйтесь оператором while.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lirene
Tyukalova
Середа-Сергеенков980
abramovae
Девяткина_Арсений
andrew-lev2501
natalia595977
zdv686857
faberlic0168
maroseyka
ganzashop
Nikolaevich824
борисовна Елена78
k-serga1
natalia595977