vetrov1
?>

Написать программу в паскале. на вход подаётся x на выход y=5*x если x> 0 y=x*x иначе

Информатика

Ответы

dianabuchkina
//Pascal ABC.NET 3.1 сборка 1256

Var
 x,y:real;
begin
readln(x);
if x>0 then y:=5*x else y:=x*x;
writeln(y);
end.

Пример ввода:
-1.1
Пример вывода:
1.21
boykovandrew6663

{ Треугольник задан координатами вершин (x1;y1),(x2;y2),(x3;y3).

Найти площадь треугольника (используя формулу Герона) }

uses crt;

var x1,x2,x3,y1,y2,y3,a,b,c,s,p : real;

begin

clrscr;

write('x1=');readln(x1);

write('y1=');readln(y1);

write('x2=');readln(x2);

write('y2=');readln(y2);

write('x3=');readln(x3);

write('y3=');readln(y3);

a:=sqrt(sqr(x1-x2)+sqr(y1-y2));

b:=sqrt(sqr(x2-x3)+sqr(y2-y3));

c:=sqrt(sqr(x3-x1)+sqr(y1-y3));

p:=(a+b+c)/2;

s:=sqrt(p*(p-a)*(p-b)*(p-c));

write('s=',s);

readln;

end.

формула герона!

А так я думаю эти задачки очень даже не сложные, только формулы надо знать!! !

периметр- это сумма всех сторон

например

begin

writteln( 'введите 3 стороны' ) ;

readln(a,b,c);

writeln(' периметр = ',a+b+c);

readln;

end.

Вот и все!! !

Удачи!

potemkin77

Уже в начале следующего года в свободной продаже должен появиться новый вид памяти NRAM (nonvolatile random-access memory). Это будет первое компьютерное устройство, созданное с использованием нано-технологий (отдельные части памяти будут размером всего в несколько миллиардных долей метра, то есть в несколько атомов). Эксперты предрекают, что NRAM произведет революцию в области устройств хранения информации и полностью заменит существующие виды памяти уже к 2006-2007 году. Характеристики новой памяти кажутся фантастическими: использование нано-технологий позволяет увеличить плотность записи информации почти в 100 раз и скорость обмена информаций - почти во столько же. В результате минимальная емкость новой памяти будет составлять 10 Гбайт. А уже к середине следующего года производители обещают выйти на 50-гигобайтный уровень, что сопоставимо с емкостью жестких дисков современных винчестеров. Используемая сейчас память DDR хотя и появилась всего около года назад, но конкурировать с нано-технологией она не в состоянии: максимальный объем такой памяти ограничен сейчас 2 Гбайтами, а 10 Гбайт, с которых начинается NRAM, считается технологическим пределом DDR. Такие характеристики позволят нано-разработкам очень быстро вытеснить все существующие виды памяти, предрекают эксперты.

Но одной памятью применение нано-технологий не ограничивается. Нано-устройства постепенно выходят из лабораторий. Если в году объем рынка нано-технологий составил всего 2,5 млрд. евро, то уже в 2010 году, по прогнозам специалистов, он достигнет 100 млрд. евро, а к 2015 году - превысит 1 трлн. евро. И это не предел, а вполне возможно, весьма заниженные оценки. Ведь нано-технологии могут применяться во всех отраслях: от авиастроения до производства одежды и лекарств. Их использование перевернет представление о возможностях современной промышленности. Материалы, созданные в наномире по прочности будут в сотни раз превосходить сталь и при этом весить - в шесть раз меньше. Прототипы подобных материалов уже существуют, но пока их производство слишком дорого. Однако кое-что уже входит в повседневную жизнь: в Японии уже запущена в промышленное производство гибкая солнечная батарея, толщиной в несколько атомов, ею планируется покрывать всю поверхность автомобилей, использовать при производстве одежды и сотовых телефонов. Эти устройства станут полностью энергонезависимыми, получая электричество за счет преобразования солнечной энергии.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале. на вход подаётся x на выход y=5*x если x> 0 y=x*x иначе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nertman45
Николаев
nsn-2012
Даниил247
opel81
Тимур
egolopuzenko4253
banketvoshod
Стефаниди
Peshkov
Sonyamaslo6
marysya60
Nadezhda Malakhov53
самир1078
ivan-chay19