linda3930
?>

Составьте программу, которая предлагает ввести с клавиатуры две строки, а затем выводит эти строки в алфавитном порядке.

Информатика

Ответы

vusokaya13
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  Writeln('Введи две строки');
  ReadArrString(2).Sorted.Println(NewLine);
end.

Тестовое решение
Введи две строки
Это первая из введенных строк
Это вторая из введенных строк
Это вторая из введенных строк
Это первая из введенных строк
Vuka91

Объяснение:

Искусство орнамента очень древнее. Возникло  оно в эпоху палеолита. Орнаментальные изображения доставляют эстетическое наслаждение, оказывающее сильное воздействие на человека, вызывают  цепочки ассоциаций, позволяющие понимать и ценить произведение.Основной закономерностью орнамента является периодическая повторяемость  мотива. Для орнамента характерны так же перевод  реальных форм  и предметов  в условные орнаментальные  изображения, высокая  степень декоративного  обобщения, отсутствие  воздушной перспективы (плоское изображение).

Орнамент всегда широко применялся в качестве декоративного оформления изделий, необходимых людям в быту и практической деятельности. Он составляет основу декоративно-прикладного искусства. Без орнамента не обходятся в изделиях художественных промыслов, керамике, текстиле.

Все орнаментальные рисунки по их изобразительным возможностям подразделяют на три вида: орнамент изобразительный, включающий в себя конкретный рисунок человека, животных, растений, пейзажные или архитектурные мотивы, рисунок предметов неживой природы или сложную эмблему;

орнамент неизобразительный, образованный из геометрических элементов, абстрактных форм, лишенных конкретного предметного содержания;

орнамент комбинированный, представляющий собой сочетание изобразительных мотивов или отдельных элементов, с одной стороны, и абстрактных форм – с другой.      

artem-whitenoise142

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

#include <stdio.h>

#include <malloc.h>

 

int main(void)

{

   int *x, n, i, m, q=0;

 

   printf("Enter the size of the array ");

   scanf_s("%d", &n);

   x = malloc(n * sizeof(int));

 

   for (i = 0; i < n; i++)

   {

       printf("a[%d] = ", i+1);

       scanf_s("%d", &x[i]);

   }

 

   for (i = 0; i < n; i++)

   {

       for (m = 1; m > i && m <= n; m++)

           if (x[i] != x[m])  

               q += 1;

   }

 

   printf("The quantity of different numbers is %d", q);

 

   free(x);

   getch();

   return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая предлагает ввести с клавиатуры две строки, а затем выводит эти строки в алфавитном порядке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Stepanovich_Makarov
anovikovsr
Leonidovich_Elena771
gusrva3001
Bogataya Vladimir318
nunabat457
aci2003
ksenia15-79
alexseyzyablov
tarhan1221
annakuznetsova841
Chuhnin195107364
mishamedbrat
Ofelya1308
razumeiko0790