Naumenkova-Ivanov
?>

Работа с системой программирования на языке Паскаль 1) Напишите программу для реализации следующего сценария: • целочисленный массив заполняется случайными числами (размерность массива и числовой диапазон определите самостоятельно); • выводится сообщение «Заполненный массив»; • с новой строки выводятся элементы массива в строку через пробел; • выводится сообщение «Введите значение числа К»; • запрашивается ввод с клавиатуры целочисленного значения числа К; • выводится сообщение «Элементы массива, кратные К»; • осуществляется поиск в массиве элементов, кратных числу К; • выводятся элементы массива, кратные числу К.

Информатика

Ответы

MikhailovichKrizhnaya578

1.Постановка задачи разрабатывается организацией, разработчиком программной продукции, на основании технического задания совместно с заказчиком. Главный исполнитель — это разработчик

2.Алгоритм-Последовательность действий, приводящих к результату.

Блок-схема- Графический записи алгоритма.

Исполнитель алгоритма-Человек, компьютер, автомат.

Язык программирования-Знаковая система для записи компьютерных программ.

Программа-Последовательность действий, приводящих к результату.

Объяснение:

Удачи тебе в учёбе!

olgalooo

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Работа с системой программирования на языке Паскаль 1) Напишите программу для реализации следующего сценария: • целочисленный массив заполняется случайными числами (размерность массива и числовой диапазон определите самостоятельно); • выводится сообщение «Заполненный массив»; • с новой строки выводятся элементы массива в строку через пробел; • выводится сообщение «Введите значение числа К»; • запрашивается ввод с клавиатуры целочисленного значения числа К; • выводится сообщение «Элементы массива, кратные К»; • осуществляется поиск в массиве элементов, кратных числу К; • выводятся элементы массива, кратные числу К.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vova00831
Batrakova-Anna
olgapotapova
eurostom
Columbia777
praktikadok
metrikajulia
perova-s200
Орлова
proh-dorohova5244
egorov
Arzieva Abdulmanov1438
skononova01
xalina85
ank9809