guujuu
?>

Написал прогу, но сайт не принимает решение. в чем ошибка? и можно ли по-другому составить программу? нужно было найти второй максимальный элемент последовательность состоит из различных натуральных чисел и завершается числом 0. определите значение второго по величине элемента в этой последовательности. числа, следующие за числом 0, считывать не нужно. program r1; var max1, max2, k: longint; begin readln (k); max1: =k; max2: =k; while k< > 0 do begin readln (k); if k> max1 then begin max2: =max1; max1: =k; end; end; writeln (max2); readln; end.

Информатика

Ответы

KrisTinka
Пробуй через массив, это куда эффективней, и почитай про сортировки массива (в частности метод пузырька), удачи с:
ooo-krasa

1. Переменная – это «именованное хранилище» для данных. Мы можем использовать переменные для хранения товаров, посетителей и других данных.

2.Трансля́тор — программа или техническое средство, выполняющее трансляцию программы. Трансля́ция програ́ммы — преобразование программы, представленной на одном из языков программирования, в программу на другом языке. ... Выходной язык называется целевым языком.

3.Язы́к программи́рования — формальный язык, предназначенный для записи компьютерных программ[1][2]. Язык программирования определяет набор лексических, синтаксических и семантических правил, определяющих внешний вид программы и действия, которые выполнит исполнитель (обычно — ЭВМ) под её управлением.

:)

sveremeev816

Microsoft Image Composite Editor - продвинутый сшиватель панорамных изображений. Приложение берет набор перекрывающихся фотографий сцены, снятой с одного места камеры, и создает панораму с высоким разрешением, включающую все исходные изображения в полном разрешении. Сшитую панораму можно сохранять в самых разных форматах, от распространенных форматов, таких как JPEG и TIFF, до плиточных форматов с несколькими разрешениями/

ДОСТОИНСТВА:  бесплатная программа, быстро скачивается и легко устанавливается, можно делать панорамы из видео.

НЕДОСТАТКИ:  управление только на английском языке

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написал прогу, но сайт не принимает решение. в чем ошибка? и можно ли по-другому составить программу? нужно было найти второй максимальный элемент последовательность состоит из различных натуральных чисел и завершается числом 0. определите значение второго по величине элемента в этой последовательности. числа, следующие за числом 0, считывать не нужно. program r1; var max1, max2, k: longint; begin readln (k); max1: =k; max2: =k; while k< > 0 do begin readln (k); if k> max1 then begin max2: =max1; max1: =k; end; end; writeln (max2); readln; end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mail5
gaina6678
nusupova
Олег2014
jgaishun756
info-mosbalkon
korolev-comitet8825
Тарбаева1243
nadlen76
Yeliseeva Verevkin864
kulagin777
Galiaahmatova4447
Nasteona1994
Алина Ракитин1730
agutty3
▲