Поскольку числа записаны в порядке убывания, одна сумма цифр двух разрядов равна 13, другая — 11. Чтобы число было наименьшим, необходимо, чтобы в старших разрядах находилась как можно меньшая цифра, следовательно сумма старших разрядов должна быть меньшей. При разложении 11 на слагаемые необходимо, чтобы одно из них было минимально возможным, поэтому представим 11 как сумму 2 и 9, это — первые две цифры искомого числа. Вторые две цифры получатся разложением числа 13 на слагаемые: 4 и 9. Следовательно, ответ 2949.
ответ: 2949.
Вот и все!
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, заменяющую меньшее из двух данных чисел их суммой, а большее - удвоенным произведением этих чисел.
Program pf;
var x,y,a,b:integer;
begin
read(x);
read(y);
a:=x; b:=y;
if x>y then begin x:=a*b; y:=a+b; end else begin x:=a+b; y:=a*b; end;
write(x,y);
end.