Sukharev-Achkasov
?>

Нужна программа на pascalabc, кто может . билет считается счастливым, если в его n-значном номере сумма первых [n/2] цифр равна сумме [n/2] последних цифр (при нечетном n центральная цифра в “проверке на счастье” не участвует и может быть любой подсчитайте число счастливых билетов с различными n-значными номерами (ведущие нули в номерах возможны, но номера, состоящего из одних нулей, не существует). входные данные на вход программе подается натуральное число n < 16. выходные данные выведите количество n-значных счастливых билетов.

Информатика

Ответы

Станислав Валерий1696
Var
 a: array [0..8,0..80] of int64;
 i,j,k,n,m: integer;
 s: int64;
begin
 read(n);
 m := n div 2 * 10;
 for i := 0 to n div 2 do
 for j := 0 to m do
   a[i,j] := 0;
 a[0,0] := 1;
 for i := 1 to n div 2 do
 for j := 0 to m do
 for k := 0 to 9 do
  if j - k >= 0 then
  a[i,j] := a[i,j] + a[i-1,j-k];
 k := n div 2;
 s := 0;
 for i := 0 to m do
  s := s + sqr(a[k,i]);
 if n mod 2 <> 0 then
  s := s * 10;
 s := s - 1;
 write(s);
end.
Tatianamir765654

10000x4000x500x30x4

Цифры числа расположены в определенных позициях, которые соответствуют (справа налево) единицам, десяткам, сотням, тысячам и так далее. Определите название позиции и ее значение для каждой цифры (справа налево).

Пример: так как в данном числе четыре цифры, то вам нужно определить названия четырех позиций (справа налево).

7 соответствует единицам (значение = 1).

2 соответствует десяткам (значение = 10).

8 соответствует сотням (значение = 100).

5 соответствует тысячам (значение = 1000).

hrim5736
1) один символ (например буква) = 1 байт. 1 байт = 8 бит (или по другому - 8 разрядов). Некоторые символы, например иероглифы не умещаются в 1 байт потому что их много, поэтому для них используют не один байт, а больше. Если для символа нужно больше 8 бит, то прибавляют не недостающее число битов, а удваивают число байт. Поэтому буквы (символы) или 8-ми разрядные (1 байт), или 16-ти разрядные (2 байта), или 32-х разрядные (4 байта).
2) МАМА - это 4 обычных символа, или 4 байта (32 бита).
3) один байт, или 8 бит.
4) 15 байт - количество всех букв + пробелы + точка. Или 120 бит.
5) 21 байт, или 168 бит (все буквы + пробел + точка).
6) 7 букв = 7 байт.
7) 20 х 40 = 800 символов/страница. 2 страницы = 1600 символов. 1600 символов = 1600 байт, или 1600 х 8 = 12800 бит.
8) 20 байт.
9) большой латинской "ай" - "I".
10) латинская буква "N".
11) маленькая латинская "ай" - "i". Из формулы Хартли N=2^{i}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужна программа на pascalabc, кто может . билет считается счастливым, если в его n-значном номере сумма первых [n/2] цифр равна сумме [n/2] последних цифр (при нечетном n центральная цифра в “проверке на счастье” не участвует и может быть любой подсчитайте число счастливых билетов с различными n-значными номерами (ведущие нули в номерах возможны, но номера, состоящего из одних нулей, не существует). входные данные на вход программе подается натуральное число n < 16. выходные данные выведите количество n-значных счастливых билетов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dmitrij-sp7
supercom-ru-marinaguseva4267
Viktor1316
bolosolo77
SVETLANAluiza1534
kabanovae
tomogradandrey
shuttse
Alesander-Isaev684
Николаевна
Ubuleeva826
b3dllam
NikolayGoncharov
mg4954531175
koeman