sev-94428
?>

Тело падает с ускорением g. определить пройденный телом путь h-gt^2/2 после первой и второй секунд падения. нужно написать программу в паскале, .

Информатика

Ответы

Grigorevna23
/*Я, конечно, не тру физик, но пройденный телом путь вычисляется не так*/
//Pascal ABC.NET 3.2 сборка 1318

Const 
 g=9.832;

Var
  h:real;
  i:integer;
begin
  readln(h);
  for i:=1 to 2 do
  writeln(h+(g*sqr(i))/2); //если что, поправите
end.

Пример ввода:
2
Пример вывода:
6.916
21.664
okykovtun31
// PascalABC.Net 3.0, сборка 1052
const
  nn=100;
var
  a:array[1..nn] of integer;
  p,s:longint;
  i,n:byte;
begin
  Write('Введите количество элементов в массиве: '); Read(n);
  Writeln('Вводите целочисленные элементы массива через пробел');
  s:=0; p:=1;
  for i:=1 to n do begin
    Read(a[i]);
    if i mod 2 = 0 then p:=p*a[i];
    s:=s+a[i]
  end;
  Writeln('Произведение элементов с четными номерами: ',p);
  Writeln('Среднее арифметическое элементов: ',s/n)
end.

Тестовое решение:
Введите количество элементов в массиве: 10
Вводите целочисленные элементы массива через пробел
-4 6 11 8 12 21 7 13 9 -15
Произведение элементов с четными номерами: -196560
Среднее арифметическое элементов: 6.8
Svetlana1287
// PascalABC.NET 3.3, сборка 1607 от 31.12.2017
// Внимание! Если программа не работает, обновите версию!

type
  R=sequence of integer;

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var P:R->BigInteger:=t->t.Aggregate(BigInteger(1),(p,q)->p*q);
  if P(a.Where(t->t.IsEven))>P(a.Where(t->t.IsOdd))
  then Writeln('Номер максимального элемента: ',a.IndexMax+1)
  else Writeln('Номер минимального элемента: ',a.IndexMin+1)
end.

Примеры
n= 17
31 98 7 42 -70 -98 -34 43 -48 -40 -28 -35 15 26 25 1 -66
Номер минимального элемента: 6

n= 15
95 88 -82 96 87 -68 17 40 -66 1 60 -25 -78 -55 -55
Номер максимального элемента: 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тело падает с ускорением g. определить пройденный телом путь h-gt^2/2 после первой и второй секунд падения. нужно написать программу в паскале, .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ragimovelshad
avdeevo
Shipoopi8
Vladimirovna-Ignatenko1890
Novikova Aleksandrovna
Манько_Панферов
Petrushin482
meteor90
valerii_Georgievna915
svetegal
bergamon
gulyaizmailova
Анна1417
lbeglarova6
maksimforyou20
▲