Shipoopi8
?>

Составить программу на языке pascal: решить квадратное уравнение вида а*х*х+в*х+с=о для произвольных а, в, с.

Информатика

Ответы

suxoruchenkovm171
Текст плохо форматируется, поэтому скину файлом.
Vladimirovich351
//Pascal
var
  a, b, c, d, x1, x2: real;
begin
  write('Введите a = '); readln(a);
  write('Введите b = '); readln(b);
  write('Введите c = '); readln(c);
  if ((a = 0) and (b = 0) and (c = 0)) then
    writeln('X любое')
  else
  if a <> 0 then
  begin
       d := sqr(b) - 4 * a * c;
       if (d > 0) then
       begin
            x1 := (-b+sqrt(d))/(2*a);
            x2 := (-b-sqrt(d))/(2*a);
            writeln('x1 = ', x1);
            writeln('x2 = ', x2);
       end
       else
       if d = 0 then
       begin
            x1:=-b/(2*a);
            x2:=x1;
            writeln('x1 = ', x1);
            //writeln('x2 = ', x2);
       end
       else
       if d < 0 then
          writeln('Корней нет.');
  end
  else
  if (a = 0) and (b = 0) then
    writeln('Решений нет.')
  else
  if (a = 0) then
  begin
    x1 := (-c)/b;
    writeln('x = ', x1);
  end;
end.
Semenovt

1)Монитор,(на счет магнитофона не уверен, сам по себе именно магнитофон никак не является устройством ПК, но если подразумевают пол этим словом динамик ПК, то подходит)

2)Получение

3)Электрический ток

4)Анатомический муляж

5)102 бита

6)48

7)из перечисленных ниже нет верного ответа. 568 в десятичной = 1 000 111 000 в двоичной.

8)АВИБА

9)Представленные ответы неправильны, так как не являются двоичным кодом(присутствуют двойки)+не указано к какой системе счисления принадлежит y (если x - очевидно 16-ти ричная, то y может быть как 16 так и 10

10) И снова нет верного ответа из предложенных, т.к. получится D8

11)800 бит

12) (Ячейки excel где?)

13) Аналогично 12

14)тоже

15)27

16)User-name

17)c*.c*

18)145.92.128.0

19)Верного ответа нет. Правильно: 22

20) 5

Объяснение:

Irina_Nevretdinova1630

Основная идея состоит в том, что каждая сумма – это сумма цифр, то есть она не может быть больше 18. Значит, надо разбивать каждое возможно получившееся число на однозначные и двузначные числа и смотреть, может ли такое быть.

1212 – возможно, например, из числа 666 (6+6 = 12, 6+6 = 12, итог: 1212)

129 – возможно, например, из числа 936 (9+3 = 12, 3+6 = 9, итог: 129)

123 – возможно, например, из числа 930

1218 – невозможно. Это число можно разбить только на два двузначных числа, но тогда 12 и 18 записаны в порядке возрастания, а по условию должно быть наоборот

1812 – возможно, например, из числа 993

312 – невозможно. Это число можно разбить либо на 3 и 12, либо на 31 и 2. В первом случае числа расположены в порядке возрастания, а во втором нельзя получить 31, так как сумма цифр не больше 18

912 – невозможно (аналогично с 312)

112 – возможно, например, из 920

Итого 5 чисел могут получиться.

ответ: 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке pascal: решить квадратное уравнение вида а*х*х+в*х+с=о для произвольных а, в, с.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna-Ignatenko1890
Манько_Панферов
ирина Альбертовна
ivanov568
Avdeeva Inga1505
Vladstreletskiy
borisovaks496
nailboxru
alfastore4
skryabinamaria
kirillreznikov
nadezhda81
coalajk
Kashirina
innaterenina
▲