ustinov434
?>

Написать программу в си++. такая : если сумма трёх попарно различных действительных чисел x, y, z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. заранее ))

Информатика

Ответы

asskokov
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {float x,y,z=0;
 cin>>x>>y>>z;
 if(x+y+z<1)
  {float min=x;
  if (min>y) min=y;
  if (min>z) min=z;
  if (min==x) x=(y+z)/2;
  if (min==y) y=(x+z)/2;
  if (min==z) z=(x+y)/2;}
  else
  if(x>y) y=(x+z)/2; else x=(y+z)/2;
 cout<<x<<" "<<y<<" "<<z<<" ";
 return 0;}

Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
alicia179
Var
begin
readln(n);
if n=1 then begin writeln('1 месяц');writeln('кол-во дней');end;
if n=2 then begin writeln('2 месяц');writeln('кол-во дней');end;
if n=3 then begin writeln('3 месяц');writeln('кол-во дней');end;
if n=4 then begin writeln('4 месяц');writeln('кол-во дней');end;
if n=5 then begin writeln('5 месяц');writeln('кол-во дней');end;
if n=6 then begin writeln('6 месяц');writeln('кол-во дней');end;
if n=7 then begin writeln('7 месяц');writeln('кол-во дней');end;
if n=8 then begin writeln('8 месяц');writeln('кол-во дней');end;
И так до 12 раз...
Я не уверен что тебе нужен такой монстр...
В место к примеру 1 месяца пишешь январь...
Косарев
Const n=8;
var 
a:array[1..n,1..n] of integer;
i,j,k,s,s1,si,dmin,smin:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
write('k = '); readln(k);
s:=0;
for j:=1 to n do s:=s+a[k,j];
writeln('s = ',s);
dmin:=999999; smin:=999999;
for i:=1 to n do
 if i<>k then
  begin
  s1:=0; 
  for j:=1 to n do s1:=s1+a[i,j];
  writeln('s',i,' = ',s1);
  if abs(s1-s)<dmin then begin dmin:=abs(s1-s); smin:=s1; si:=i; end;
  end;
writeln('Номер строки = ',si,', smin = ',smin);
end.

Пример:
Исходный массив:
   9   0  22  40  20  35   2  25
  23  30  22  35  41   0   9  40
   1  15   6  18  43  47  34  33
  26   5   2  45  13  46  40   2
  26  39   7  31   3  43  20   8
  25  15  24   6  10  16   3  25
  47   0  27  35  14  15  36  11
  16  38  14  14  33   7  11  26
k = 5
s = 177
s1 = 153
s2 = 200
s3 = 197
s4 = 179
s6 = 124
s7 = 185
s8 = 159
Номер строки = 4, smin = 179

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в си++. такая : если сумма трёх попарно различных действительных чисел x, y, z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. заранее ))
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bespalovaannaanna
hello
Marinanagornyak
egcuzn86
vmnk38
Yevgenii1423
Andrei_Mariya
asvavdeeva
Alekseevich_Viktorovna
GoncharenkoKuzmin
Каныбек698
Vladimirovna1858
beliaeva2
lihacheva
kogakinoa